0

I have a pretty weird issue with my text editor. First, my website is under development (in local) and is made with the Shapely free theme. Secondly, my website is for job hiring purpose (using the WP Job Manager plugin).

So on my website I have a page where people can create job offers (directly from the website, not going in the admin panel) and there's a description field of course with a text editor and this text editor is the issue. This text editor doesnt changes when I modify the TinyMCE features in the Admin panel; even checking the box "modify front end text editor" doesnt change anything in the fornt end text editor.

Weird thing also I can see that TinyMCE is loaded on the front end editor through the source code of the page.

Hope you guys may help

0

"modify front end text editor" is not an option anywhere in WordPress. You must have a theme or plugin that's adding this option. WordPress has no UI for modifying the editor at all.

The problem is that WP Job Manager is probably not using the same 'front end text editor' that this theme/plugin is referring to. The theme/plugin that's adding this option probably uses a filter that applies to certain instances of the editor, but WP Job Manager likely doesn't use it that way, which means that whatever filter is being used isn't applying to it.

If you want to modify the WP Job Manager front-end text editor you'll need to ask its developer, or check the documentation, for a method to do this.

  • Okay i'll try to ask both of them which text editor they're using – B.Felix Oct 31 '18 at 9:39
-1

I had to edit the attributes in the wp-editor-field.php in the WP Job Manager plugin folder with TinyMCE attributes such as forecolor,alignleft,etc...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.