0

I am using the twentyfifteen theme on my wordpress site. When you access the site on mobile or resize on your browser so that the page height > width, a hamburger icon appears on the upper right. I used to be able to click on this button and see my main navigation menu.

For some reason, the button has stopped working. It does absolutely nothing when you click on it. I checked it out with the inspector, it's a button and the class is secondary toggle.

There is no error message appearing in the console.

I went on an example page, and the code in the inspector looks a bit different there:

<button class="secondary-toggle" aria-expanded="false" aria-controls="secondary">Menu and widgets</button>

Mine appears like so in the inspector:

<button class="secondary-toggle">Menu and widgets</button>

I tried adding the aria control stuff manually into my code, it then appears on the inspector but I'm still not able to open the menu.

Has anyone else experienced anything similar? Any tips on how to get it working again?

Thank you!

UPDATE: I had taken out a lot of the stuff in footer.php and replacing it seemed to make the aria-controls stuff reappear. Now the html for my button looks exactly the same...but, the menu button still doesn't toggle.

  • Try check your console for any (javascript) error msg after clicking the hamburger button. – rony2k6 Oct 31 '18 at 1:02
  • @rony2k6 there is no error message in appearing in the console – ellen Oct 31 '18 at 1:17
  • can you share the link, so that I can inspect myself? pls don't comment you're not interested to share link. – rony2k6 Oct 31 '18 at 1:19
  • @rony2k6 actually, I am running on localhost. The site is not live yet, I'm fixing all the bugs first – ellen Oct 31 '18 at 14:37
  • I'll see if I can get some more info – ellen Oct 31 '18 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.