3

I'm maintaining a WordPress site on GoDaddy for a client and they started to get the "this link has expired error" when they saved a post. It does not happen when I upload a file. However, I am getting an "http error" error when I try and upload a file.

I've done some research, everyone who experiences this error seems to find a solution with updating the php config files to allow larger uploads, longer input times and so forth. This did not seem to work. I've included the phpinfo information below just incase.

From what I've gathered it seems to be an issue with the Nonces, but the clients did not update any plugin or update wordpress. Nothing should have changed, and I don't have enough experience to understand what's happening here.

Here is what I have done:

  • Disabled plugins
  • Changed themes
  • Updated php config to reflect changes below
  • Updated php to 7.2

php info page screenshot php info page screenshot php info page screenshot

Any ideas?

EDIT: When I update the Authentication Keys and Salts (from here), it works once and then stops working.

EDIT2: I discovered the theme is the culprit (Jupiter 6). However, once de-activated, the situation still happens until my cookies are cleared and I log out and back in. Updating and installing the theme again does not seem to have solved the problem. On a fresh install of wordpress, the theme works fine.

  • Server issue, I guess. Perhaps GoDaddy can help you.. Or check the .htaccess file and custom php.ini file, if any. See also Debugging in WordPress. – Sally CJ Oct 30 '18 at 18:25
  • What am I looking for in either of these? – Jersh Oct 30 '18 at 18:54
  • 2
    I meant php.ini... But anyway, I'm not an expert and just trying to give you some ideas which I hope would bring you to the solution of the issue. Cheers! – Sally CJ Oct 30 '18 at 20:02
  • 2
    By "fresh install", you mean with all the default WordPress data (posts, themes, plugins, etc.)? And I'm not sure what's wrong, but try these as a workaround: 1) Back-up/export your database; 2) Import the database from the WordPress site with the fresh install (everything is default); 3) Install all the active plugins from the problematic site (and I mean, don't copy the plugin files - install them manually). Then check if the issue persists. (All these steps take time, but worth trying) – Sally CJ Nov 14 '18 at 22:19
  • 1
    Ah, okay. :) And I was actually also going to say, try a different computer, smartphone, tablet, etc., and even try using someone else's Internet connection? :D I mean, it's possible that there's something (like a setting, maybe) in your computer/device which is making the site (and just that site) to not work for you... – Sally CJ Nov 22 '18 at 17:11
0

I am also under same issues, it not only happen when you update a posts but also when you try to update your profile.

Temporary fix:

  1. Log out of the wordpress panel.
  2. Clear or remove all the cookie.
  3. Log back in, remember to check remember me.

This seems to solve the issue but as the cookie of remember me will expire which is after 15 days of your log in date. You again have to do all the above steps.

I guess there is something with the Godaddy hosting, not our plugins, themes or browser.

Are you facing issues with classic editor, it default open text tab and the icons are white.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.