I asked this question and got no help at Wordpress.org.

Here it is:

When I go to my Media Library, I can’t see any of the images:

Screenshot: https://postimg.cc/gallery/2rwihw1ty/

Not sure what’s causing this. I attached an image also of the plugins we have installed.

No one could give a clear answer on the issue. Where to start? What to check?



  • Try a default theme like Twenty Seventeen. – Sally CJ Oct 30 '18 at 1:36
  • Can you click on the list view in the media library? and let me know what is the output. Please see this url – sleepingpanda Mar 11 at 11:18

Usually, the determination of the culprit involves one or more of the following:

1) Try one of the Twenty themes.

2) Disable all plugins (quickly via FTP renaming the plugins folder).

If a theme, contact the theme support.

If a plugin, add plugins one at a time (create a new plugins folder,them move plugin folders into there one-two at a time, until the problem reoccurs). When you determine the at-fault plugin, contact the plugin's support forum.

This assumes that you haven't moved domains lately (moving domains requires search/replace of the old/new domains in the database to update things).

| improve this answer | |
  • Thanks Rick. Really appreciate it. Neither of those did the trick. I tried the 2015 theme. And also disabled all the plugins from within WP because we simply don't have that many. I forgot to mention we did switch hosting services from GoDaddy to Bluehost. What issues could that have caused with this? – Dan Nov 1 '18 at 1:21
  • You might need to look inside the wp_posts table (which is where all types of posts are stored: pages, posts, media, etc) and look for the file name of a post entry. Then look at the fields to see if the full URL is correct. If not, repeat with other records to find a pattern. You may need ot use a plugin like "Better Search and Replace" to fix bad URLs. This assumes that there are actually files in the uploads folder, which is where media files are stored. – Rick Hellewell Nov 1 '18 at 1:34
  • I think herein lies the problem. When I click the image file in the media library, I can see the path is something like redemptionwels.com/wp-content/uploads/2018/09 but no such folder or file exists when I go to cpanel's file manager to check this manually. So, how do I get Wordpress to understand where to upload files and where to look for them? – Dan Nov 7 '18 at 1:29
  • The default place for uploads is in the wp-content/uploads/YYYY/MM folder. If you want to change that, you change the value in wp-config.php: define(‘UPLOADS’, ‘wp-content/myimages’); . See premium.wpmudev.org/blog/… for more info. Or, you could just move all of your uploads into the default location. – Rick Hellewell Nov 7 '18 at 2:56
  • ...So I did that and verified the files are present. And I verified from WP that it understands the correct path. Both are 100% accurate. Yet, the problem persists. What could be going on? – Dan Nov 11 '18 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.