0

Wordpress 4.9.8 when I save a draft/publish return me an error:

    Gone

The requested resource
/wp-admin/post.php
is no longer available on this server and there is no forwarding address. Please remove all references to this resource.

I found that the problem is because my text has " style="bla bla bla" ". If I remove style= it works. I tried disabling all plugins, change to default theme, create a new installation, change PHP version from 5.6 to 7, 7.1, 7.2 : doesn't change.

Any ideas?

2
  • I cannot replicate this error, so it must have something to do with your particular setup.
    – cjbj
    Oct 29, 2018 at 16:19
  • This sounds like something mod_security or some kind of firewall might do.
    – Milo
    Oct 30, 2018 at 0:22

3 Answers 3

1

I've had the same issue recently.

Inline styles, as well as <img> tags, would cause the 410 Gone status and error message (The requested resource /wp-admin/post.php is no longer available on this server and there is no forwarding address. Please remove all references to this resource. upon previewing or publishing the post.

The problem was due to the hosting provider doing some maintenance on mod_security in cPanel.

I found out when I asked them for the Apache logs so that I could look into it more.

Contact your hosting provider to get this fixed.

1
  • Hi Francensco, my provider too (www.register.it). Disabling and re-enabling mod_security, the problem is solved.
    – Aculine
    Oct 31, 2018 at 14:38
1

SOLVED:
as @milo suggests, I found solution disabling mod_security under cPanel. So I ask to my hoster (register.it) if there was some problem. They confirm me that servers are under updating security stuff and to disable and then re-able mod_security in CPanel. After that, post.php works properly.

Thank you all.

0

in general it's not a good idea to insert inline styles.

try with a CSS class and add your custom CSS to your theme.

1
  • That's always true, but when clients copy/paste from Word or other stuff, I cannot always clear HTML...
    – Aculine
    Oct 30, 2018 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.