1

I just got my hands on a WordPress site and i'm trying to edit some words from a theme login template, so I went to cPanel to check how the theme templates handle the copy and I found the pt_PT.po with the words I was looking for.

After understanding a bit better how .po and .mo files work, I installed LOCO translations plugin to edit those files and I found the phrases I was looking for, edited and saved them.

I went back to cPanel and the .po file was changed with the copy I wanted, but there were no changes to the site, even after cleaning the cache. .mo file was also changed because had the same "last modified" timestamp.

I read in other answers that adding define('WPLANG', 'your_language'); to the wp-config.php would do the trick, but since this site already has the translations from English to Portuguese online it didn't make sense to me to add that line.

I'm I wrong and I still need to add it or is it something else?

Thanks!

  • 1
    In WordPress 4.0 and above, you should set your site's language via this page: Settings > General > Site Language and no need to define the WPLANG. – Sally CJ Oct 24 '18 at 0:04
  • There are dozens of possible causes. Provide a download link to the theme's source code and an example string you can't get to work. – Tim Oct 24 '18 at 11:16
0

i had a similar question posted some time ago: why is translation not working on theme?

it might be the solution to put your translation files into the right location (languages directory in wp-content/languages/themes/) and prefix them with the theme name like themename-pt_PT.po

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.