1

The problem I've run into is the WordPress for my website yesterday randomly stopped allowing us to edit any of the pages. Every time you click to edit a page it comes up with a 404 error.

Things I have tried so far:

  • Deactivated every plugin thinking that was the problem, but that didn't solve the issue
  • I have restarted the permalinks
  • Changed the theme
  • Even checked the code in the htacess file

The website is fully functioning and viewable to our visitors. We just can't edit any of the pages now for some reason.

1

You mentioned that you disabled all plugins, and changed the theme (I assume you used one of the 'twenty' themes, which is what I usually do when trying to find theme/plugin problems).

Did you also look at the 'must use' plugins (in wp-content/mu-plugins ) (see https://codex.wordpress.org/Must_Use_Plugins ). Maybe a plugin in there is causing problems.

I'd also look at the Network tab in Developer Tools (in your browser, usually F12) to see what request element is actually causing the 404. That might point you to the plugin/theme/whatever problem.

You could also do a re-update of WP (in the Admin, Updates) section to see if there is some missing core code.

  • Yes I had tried out twentfyfifteen, twentyfourteeen and twentythirteen themes. I was looking at the must use plugins in cpannel and had found 2 plugins. wp-login-protect and health-check-troubleshooting-mode. I tried to delete them both but when I click off the folder and back to it the files reappear. I tried using the network tab and didn't seem to find any plugin in the code. In the console it says "Failed to load resource: the server responded with a status of 404 (Not Found)" Im not too sure for the re-update of wp. Do you mean going to dashboard/updates/Re-install now? – alex5p Oct 12 '18 at 1:55
  • Yes, won't hurt to reinstall WP via Dashboard, Updates, Reinstall no. The MustUse plugins are probably placed there by another plugin; perhaps your hosting place. They should be in the Plugins page; click on 'must use' on that page to list them. You could rename those mustuse folders to disable. But contact those plugin support pages for help. – Rick Hellewell Oct 12 '18 at 18:31
1

Hey so I actually had the same problem. I accidentally solved it. If you're on Wordpress 5, they actually get rid of 'Classic Edit' so when you hit edit, the system craps itself cause the plugin isn't there anymore. THANKFULLY there is a solution. Go to your updates, reinstall wordpress, and on the finish page, scroll down to the bottom and there is a portion on classic edit. Just follow it's prompts and you're good to go!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.