Ok, I'm at wit's end with Wordpress. This is the fifth time I've tried installing it and it flat out is not working.

When I install it, it shows one of the themes, but the default welcome post doesn't show up and when I log in it won't let me with the username and password I set up. Am I doing something wrong?

The wp-config file is edited to match the db settings.

I'm getting very frustrated. I login with admin and my password and it says "error: invalid username".

How can it be invalid when I left it at the default which was the admin. What do I do now? I'm completely stumped.


No, I don't have a dedicated host or domain so I'm trying locally with xampp. and the username - password is not case-sensitive even the first letter of the username is not capitalized.

I have tried different test cases also like clear site cookies, cache, renaming plugin directory and theme directory one by one.

also, make changes in wp-config.php as follows:

define('WP_DEBUG', true);

define('WP_ALLOW_REPAIR', true);

My MySQL settings are also correct, as per standard

define('DB_NAME', 'WP');

/** MySQL database username */
define('DB_USER', 'root');

/** MySQL database password */
define('DB_PASSWORD', '');

/** MySQL hostname */
define('DB_HOST', 'localhost');

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8mb4');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

suggest me something plese.

  • The login system is case-sensitive, try "Admin". – Pim Oct 11 at 9:22
  • There is no default username WordPress. You just have entered something. If you’ve installed WordPress through your host’s control panel, then maybe it sets a default. In that case you’d need to ask your host for help. – Jacob Peattie Oct 11 at 9:40

If your database connection is wrong you will get an error says Error establishing database connection so if you seeing login form your connection is fine and wp-config has nothing to do in your issue.

If you don't remeber what's your credentials are, go to your database manager like phpMyAdmin and look for _users table and take a look what accounts are in your Wordpress installation. If you don't remember your password there is simple way to recover it from database. Edit selected user and type new password in the password column and set type field to MD5. Then your password will be pre-reset. When you'll try log in with your new credentials Wordpress will hash new password.

  • I know my credentials, and Kamil, how anyone forgets username- password in the first time? by the way, I just simply fill the login form with admin as a username and admin as a password and when it raises an error of wrong username and password, then I tried to go with "lost my password" option and a response, i got an error that this email address is not registered. – user404122 Oct 11 at 11:04

Try this:

  1. Try checking out the wp_users table in you phpMyAdmin and see what username is saved in the row.
  2. lets say the row has 'admin' as username and you see a garbled string of characters in the 'password' field (that's because WordPress stores the password by converting the password in MD5 value)
  3. change the password by editing the row containing 'admin' username and add a new MD5 encrypted password (I am mentioning the steps to change the password and save it in MD5 below)
  4. Use the username and the new password you have generated just now for logging in again.

These steps explain how to change the password in the database.

  • In the table list under phpMyAdmin, click on the users table

    Note: In my example the table prefix is "wp_" The prefix varies from site to site so don't worry if yours is different.

  • Click edit next to the user you want to set the password for.
  • Enter the new password into the password box
  • In the function box next to the password choose MD5
  • Click Go

Hope this helps solving it. If you want to debug it more deeper, let me know in comments and I will be happy to solve any other queries you have.

  • Thanks, Rahul but as I checked out but my MySQL returned an empty result set (i.e. zero rows), can you please suggest me, how would I able to get access in the Wordpress dashboard. – user404122 Oct 11 at 11:22
  • Hmm... What I suspect here is that your Wordpress installation wasn't complete and hence you're getting empty rows. You can try installing the WordPress again by deleting wp-config.php file and go to the website URL again, put your databasse username and password and hit install button! One more thing: before running the installation, make sure to drop all the tables present in the database. – Rahul Dhangar Oct 11 at 11:35
  • I have tried again the same procedure that you have mentioned above, but this also won't allow me to get into the WordPress dashboard section. – user404122 Oct 12 at 7:27
  • That's weird. If you like, I can connect with you over TeamViewer or Google Remote Desktop and diagnose the problem for you. If you want me to look at your system remotely, then ping me over Whatsapp: +919284846498 and we can carry on from there. (I'm happy to do this in order to get you over this problem so as to help you as a fellow WordPress enthusiast to grow along) ;) – Rahul Dhangar Oct 13 at 8:36
  • Glad to have such a nice person here in StackExchange, Thanks Greatly !!! but finally I solved my issue by upgrading my window 10 version that allows me to take control and get access into my WordPress dashboard over Xampp. Thanks, buddy. – user404122 Oct 14 at 15:02

Okay, let me tell you to step by step and screen after screen:

So after filling the WordPress credentials where I put admin for both username and password for simplicity and then I pressed install.

Next Screen: Blank with WordPress logo only.

Or if I tried to refresh the page then I got another screen with the following, message:

"ALREADY INSTALLED You appear to have already installed WordPress. To install please clear old database first. login in - button present"

And when I tried to log in with same credentials, it raises an "invalid user" error.

Or if I chose "Lost your password" option then it raises "There is no user registered with that email address".

To fixed this issue, I dropped the database that I had created inside the phpmyadmin control panel and create another and set up again the credential details needed to login in the WordPress.

Any Suggestions, how could i resolve this problem, thanks?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.