0

my website currently in staging site and I host it locally. Today, I upload some pictures from Live website to wp-content > upload folder but It does not show in Media library, however if I use link domain.com/wp-content/uploads/year/month/img, I can see the picture.

I've tried several things like changing the directory permissions to 777/775 but it does not work.

Any ideas?

0

Welcome to WordPress Stack Exchange community.

Actually adding media directly to uploads folder, will not be shown in WordPress Media Library as those images which you have added manually in upload folders are not stored in the database. However, if you manually use image path then they will be accessible but it will not get displayed in Media Library.

WordPress stores all uploaded media files as a media post in the database and displays them in Media Library.

So please upload all images in 'Media' in your website backend, instead of manually uploading them in the upload folder.

Hope this helps!!

enter image description here

  • Thank you so much for your reply, how about if I want to store them in different folders based on the date? Lets say 2018/5/, some of the pictures and files are linked to posts that i've shared. – t.cvmk Oct 8 '18 at 7:06
  • WordPress by default manages uploaded media in 'month- and year-based folders'. You just have to enable it from 'Media Setting' as shown in screen-shot which I have uploaded in my above answer. As per my knowledge, it is not possible to manage uploaded media in 'date-wise folders'. Also, there is a WordPress plugin available 'WordPress Media Library Folders' which provides the feature to create your own folders and manage media folder-wise in Media Library. You can setup and manually create date-wise folders using this plugin. wordpress.org/plugins/media-library-plus – dhirenpatel22 Oct 8 '18 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.