0

Hello I just finished moving my Wordpress website from my testing domain to my new domain. I Changed the urls that I needed to change in my database. I added this code to my wp-config. I changed the rest of the neccesary settings in my wp-config file.

define('WP_HOME','');
define('WP_SITEURL','');

I even downloaded a plugin to replace every instance of the old domain with the new one. And still my website loses CSS, the dashboard has some CSS but it doesnt look like it's supposed to look.

http://prntscr.com/l2jiky

In my console i see the following:

http://prntscr.com/l2jj1j

  • @SallyCJ yeah the proper theme is selected, even the admin dashboard has no proper styling for some reason – Kevin Oct 5 '18 at 13:36
  • (Ok, please ignore that.) If you haven't, try clearing your browser's and site's cache. Check also this, particularly the DOMAIN_CURRENT_SITE part. – Sally CJ Oct 5 '18 at 13:42
0

I'd vote for a browser cache clearing (Ctrl+F5 or equivalent). Or you could try another browser instance (I sometimes use a new 'private' browser instance to test things.)

I'd also look at the Network tab in Developer Tools (usually F12, or right-click anywhere in the page and select 'Inspect Element'). After displaying the Network tab, refresh the page. Then look to see if the CSS elements are coming from the right domain/IP address. If they aren't, there are changes required in your theme code. Maybe changing the theme to something else then back to the current theme would help.

Also slightly possible is your local DNS cache. At the command prompt (on a Windows box) use IPCONFIG /FLUSHDNS .Then restart the browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.