0

So I have an issue with WooCommerce translation to German language - basically it does not translate every single string. I'm using a child theme of "Neighborhood" theme and we have a plugin Loco Translate active. I've inspected .po file and it seems that every string is being translated properly, I've tried to place the file in multiple different directories based on WooCommerce localization instructions, but somehow this issue still persists.

URL to the site : https://bellajane-babyshop.de

I should mention that this issue has occured once we've switched from German to English and then back to German ( meaning after the language toggle, before the toggle site was on German and everything worked great ).

I've also tried disabling Loco Translate and tried different translation methods recommended by WooCommerce, yet still there was no change.

Any help would be appreciated!

  • I have seen WooCommerce-compatible themes use their own copy of the WooCommerce plugin translations. In that case the PO file you've translated might not be the one actually used.The only way to find out is to debug the code. (note: WP actually reads the MO files). – Tim Sep 26 '18 at 9:02
0

So as you explained I installed fresh WordPress with woo-commerce and Loco Translate is working fine, I am using storefront theme, So i guess It's something your theme is not compatible. One thing i found is that when i changed language from English to German and then back to German there were still some words left unchanged but when i removed product from cart, everything become normal. I think you should take support help if you are not able to do it yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.