1

The image in my media library is 560×315, but when I inspect the image this is the code I find. srcset images are being loaded instead of my full resolution image.

<img src="https://domain.com/feat-image-150x84.png" class="alignleft post-image" alt="Return of Medicare OEP" 
srcset="https://domain.com/feat-image-150x84.png 150w, 
https://domain.com/feat-image-300x169.png 300w, 
https://domain.com/feat-image.png 560w" sizes="(max-width: 150px) 100vw, 150px">

Despite their names (300x169.png) all of the srcset images are only 150x84.

I've tried:

  • Turning off any plugins that affect images
  • Changing the image sizes in Settings > Media
  • Regenerated every image a multiple times
  • I tried adding set_post_thumbnail_size(560, 315); to my functions.php file as someone suggested. That did make the images display in the correct dimensions, but not the correct resolution.

I even removed the srcset image links. I was hoping if I did than it would default to the full resolution.

function wdo_disable_srcset( $sources ) { return false; } add_filter( 'wp_calculate_image_srcset', 'wdo_disable_srcset' );

but that just made it worse.

How do I make WordPress use the full resolution image I uploaded?

  • Which function did you use to print the image? – Tung Du Sep 18 '18 at 4:19
  • I'm not a PHP guy so you'll have to break that down a bit more for me. – Telarian Sep 18 '18 at 14:50
  • What theme are you using? And what page is this being displayed on? – RiddleMeThis Sep 18 '18 at 15:02
  • Genesis and it's on the blog home page where all the recent posts are listed. – Telarian Sep 19 '18 at 19:58
1

Without seeing your theme setup you could try this. If you don't need that size of image, set the thumbnail size and then regenerate your thumbnails. Keep in mind this will set this size image for all thumbnails, this may not be what you want.

Add the following to your functions.php.

 set_post_thumbnail_size(560, 315);

More info on set_post_thumbnail_size.

Then regenerate your thumbnails

  • This does make the image display at the correct dimensions, but not at the correct resolution. Also, I looked all despite their titles all of the srcset images are 150x84. – Telarian Sep 19 '18 at 21:46
  • Try messing with the different settings in the more info link above – RiddleMeThis Sep 20 '18 at 0:22
  • You could go into the template and change what image size it is using. Here are the default ones. the_post_thumbnail('thumbnail'); the_post_thumbnail('medium'); the_post_thumbnail('medium_large'); the_post_thumbnail('large'); the_post_thumbnail('full'); – RiddleMeThis Sep 20 '18 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.