My concern is when I search for that company I see what is shown in the image.

Instead of Home, I require it to show a custom title that is good for SEO.

What is the best way to fix this?

Please see the attached image of the search result for the website in question.

Thanks in advance

enter image description here

1 Answer 1


Change Page Title

Many plugins and themes might be controlling this area. However, despite this, if you change your Title on the Home Page, it should update your HTML title tag also. This will then update on Google when it next indexes your site, which might take several days.

Google and other search engines use the Title Tag for the title field in search results.

Wordpress will set the Title Tag of your page using the title of your page as seen in the image below.

<title>HTML Reference</title>

enter image description here

Yoast Title Change

If you are using the Yoast SEO plugin, then you will also need to check your Yoast settings are correct. Go to the following area and check there.

SEO > Search Appearance > Content Types > Pages

Each snippet grabs the relevant data. So where you see the purple Title bubble in the below image, this is grabbing the page title you set.

enter image description here

Custom Yoast Page Title Settings

*Note: Make sure you haven't overwritten the main setting via custom settings on the actual page via the Yoast tab, as seen in the below image.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.