0

enter image description hereI have my normal HTML/CSS on my root folder and Wordpress installed in a subfolder (domain.com/subfolder). When I log into my wp-admin subfolder as admin, it directs me to a dashboard page which renders without CSS as shown in the image below.

When I click on the wordpress side menu options, it loads https://bookabucket.com/services displaying the services request wizard form. I'm beyond puzzled, i don't know what to do.

The .htaccess file within the root folder and the sub-directory both contains:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /services/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /services/index.php [L]
</IfModule>

# END WordPress

I tried the following without success:

  1. Clearing my safari browser cache....no luck.enter image description here
  • What URLs does it load? Which URLs is it trying to load but failing on? Is there anything in the JS console? The question can't be answered with only the info provided, please click edit and add extra information. Don't leave anything out even if you think it irrelevant, e.g. has it always been this way or is this new? – Tom J Nowell Sep 5 '18 at 20:41
  • A brief browse around and inspection of bookabucket.com/services suggests that permalinks are turned off, but I could not gain much more useful information relevant to this, and permalinks being turned off wouldn't cause this. Do you have examples of the broken links with the broken URLs? – Tom J Nowell Sep 5 '18 at 20:48
  • @– Tom J Nowell Thank you for your time. Well when i login to my admin dashboard, this is the URL i get: bookabucket.com/services/wp-admin And when i click Form entries option from the menu on the left, the page loads the request form wizard on the homepage instead of showing me the Gravity form entries i received. Here's the url: bookabucket.com/services/wp-admin/admin.php/?page=gf_entries About the permalinks, i can't go past the dashboard. When i click permalinks, it takes me to bookabucket.com/services – Sean P Sep 6 '18 at 15:20
0

Try disabling all plugins temporarily (you can do that quickly by renaming the wp-content/plugins folder to something else). See if that fixes the admin screen.

If it does, make a new wp-content/plugins folder, then move plugin folders from the renamed folder back into the wp-content/plugins folder one at a time. Retest, and see if one of the plugins you move back causes the problem.

It's also possible that your theme is doing it. A quick fix to check that is to rename any added theme folders (in wp-content/themes), leaving the 'twenty' themes. Since the active theme is no longer in the themes folder, WP will revert back to one of the 'twenty' themes.

Renaming the folders can be done via FTP, or your hosting File Manager. And renaming folders, while deactivating themes/plugins, will not affect those theme/folder settings. The settings will come back after you put the theme/plugin folders back where they belong. You may need to activate the plugins after you move them back.

  • hi Rick Hellewell i appreciate your time. The few things i tried out before posting the questions were: Rename all plugins within the Plugin folder, rename the plugin folder...all of the above didn't work I went in to phpmyadmin, wp-options, i searched for template and CSS. I renamed both to WordPress default twenty theme, that didn't work either. I even cleared my browser cache, didn't work. I'm actually logged in right now, but all i can see is the bookabucket.com/services with as shown in the image – Sean P Sep 6 '18 at 15:26
  • A quick look at that site shows that you are using the 'bookabucket' theme. And the page isn't fully formed (no footer/end-body tag). Lots of JS code in there too (from the theme and the 'booking' code). So looks like a theme problem. I'd reinstall WP (from the admin panel if you can, or manually, but backup your wp-config first). Then rename the 'bookbucket' theme folder to something else, so that a 'twenty' theme takes over. If you can get into admin, activate one of the 'twenty' themes. Then see if page code is OK (including end body tags). If OK, then that points to theme code problems. – Rick Hellewell Sep 6 '18 at 16:52
  • Now i'm not sure the theme's the problem. I changed the theme to the default wordpress Twentyseventeen theme and the issue persisted. One look at the bookabucket.com/services and you'll find the default theme's active. I did a fresh wordpress 4.9.8 installation here: bookabucket.com/booknow and it's running. However, i'm not sure sure how to move my content from bookabucket.com/services to bookabucket.com/booknow then change to landing page on .htaccess – Sean P Sep 10 '18 at 14:59
  • Moving content: export from the old one (in Tools), then import into the new one.That will move all content and pix and stuff. You might need to use a plugin like "Better Search and Replace" to look for old URLs. Or you could use my 'move a wordpress site' process here: securitydawg.com/moving-a-wordpress-site - it's the process I use to move WP sites from one place to another. You could also make a new WP install in a new folder on your host,move content, then just point your domain to that new folder. – Rick Hellewell Sep 10 '18 at 16:50
  • I already made a new WP install in a new folder. I'm wondering how to move my plugins with it's settings (Gravityform + entries) from the old Plugin folder to the new WP install plugin folder without losing my plugin entries – Sean P Sep 12 '18 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.