0

My WordPress dashboard has no "Appearance > Editor" menu option.

I've done a lot of searching, but all of the answers online involve plugins or define( 'DISALLOW_FILE_EDIT', true ); having been added to the wp-config.php file. I have no plugins installed yet, and the config file does not have anything about "DISALLOW_FILE_EDIT".

I even tried adding define( 'DISALLOW_FILE_EDIT', false ); into wp-config.php anyway, but it didn't help.

Anyone know what's going on?

  • 1
    It's possible your host disallows it. Worth asking them anyway. – Jacob Peattie Sep 4 '18 at 8:35
1

So, I inadvertently solved my own problem by uninstalling WordPress and reinstalling it with Multisite DISABLED. Apparently it's something about Multisite that was causing it to be hidden. Lucky for me, I don't actually need Multisite in this case.

| improve this answer | |
0

Try to check if in any function in the function.php of the theme you're using there isn't the following directive:

remove_submenu_page ( 'themes.php', 'theme-editor.php' ); // Appearance-->Editor
| improve this answer | |
  • Thanks - I didn't actually end up needing to try this, because I reinstalled without Multisite and that fixed it. So apparently it's something related to Multisite. – user26529 Sep 11 '18 at 5:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.