How Can I Manually Fix & What is The Root Cause?

The Site Language setting in Settings > General for my site, will not update.

It is stuck on English (United States).

I have done all the usually debugging procedures, such as disabling all my plugins etc, reinstalling WordPress etc. But the issue remains.

Q: What is the best way to manually fix this, and what is the root cause of the issue likely to be?

enter image description here

enter image description here

2 Answers 2


A possible source to the problem is the Divi theme, which applies its own translation settings. Try to go to Divi → Theme Options → General → Disable Translations and make sure that they are disabled and then recheck.


Another way to fix this problem is by adding this snippet to your functions.php file:

function setLocale($locale) {
    return ‘LANGUAGE CODE’;
add_filter(‘locale’, ‘setLocale’);

I had the same problem and in my case the reason why it didn't work was that:

  • I use Divi

  • in functions.php Divi has function et_divi_maybe_change_frontend_locale and it returns 'en_US' by default.

Just change 'en_US' to your language. Remember to use a child theme if you're modyfying functions.php

  • I have multiple Divi sites. It only happens to one. In functions.php there's only the following code which contains en_US, which is the same even when English UK is correctly set on other sites and if I change it manually, it makes no difference. if ( 'on' === $disable_translations ) { return 'en_US'; }
    – Electron
    Sep 11, 2018 at 9:04
  • I'm unable to tell you the exact problem but you can change that settings from the option table in the DB. Aug 23, 2020 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.