0

I created my website on the subfolder https://www.lokaction.be/dev/.

After it was finished, I moved the website's files to the main adress https://www.lokaction.be/ (ftp). And after that, I edited the siteurl and home record in the database in the wp_options table.

I have done this before, and as far as i rememeber, these were all the steps that were needed. However, as you can see for yourself, nothing is showing, just a blank page. Also no connection error, the page source is blank too.

What happened? What could be the cause? The only difference with other websites I moved is that I installed the Wordfence plugin. Could this be a problem? And mostly, were do i start to fix this issue?

  • Can you turn on the debug log via wp-config.php? codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG – sven Aug 30 '18 at 11:38
  • Done, debug is now active. – Kevin Verhoeven Aug 30 '18 at 11:49
  • Does the .htaccess mention the subfolder (eg in the RewriteBase line)? – kero Aug 30 '18 at 15:25
  • It does, but changing it from /dev/ to / didn't change anything either. Something else i can try? – Kevin Verhoeven Aug 30 '18 at 15:39
  • Log file is available in website_root/htdocs/wp-content/debug.log Can you check the file if you see anything in there? Because you seem to be getting a server 500 error. So that's probably because of your webserver or some of the code is creating a fatal error. – sven Aug 30 '18 at 16:27
0

you need to see below post to move word-press site one server to other

Ref :- Wordpress link

some simple steps follow and change site location

you can update your database using following queries

UPDATE wp_options SET option_value = replace(option_value, 'https://www.oldurl', 'https://www.newurl') WHERE option_name = 'home' OR option_name = 'siteurl';

UPDATE wp_posts SET guid = replace(guid, 'https://www.oldurl','https://www.newurl');

UPDATE wp_posts SET post_content = replace(post_content, 'https://www.oldurl', 'https://www.newurl');

UPDATE wp_postmeta SET meta_value = replace(meta_value,'https://www.oldurl','https://www.newurl');
  • I followed Moving Directories On Your Existing Server untill step 9. But i can't login or anything since the website appears to be gone. In the database, the url's in the guid field in wp_posts still contain the /dev/-part of the url. But i don't think editing them here will do much good? – Kevin Verhoeven Aug 30 '18 at 11:53
  • use mysql to update you new location – user147874 Aug 30 '18 at 11:58
  • I just used the 4 queries correctly, however, the website is still showing a blank page. This is really weird! – Kevin Verhoeven Aug 30 '18 at 12:07
  • old url: lokaction.be/dev new url: lokaction.be. I checked that the old url was the one used in the database everywhere, so it should be correct. – Kevin Verhoeven Aug 30 '18 at 12:16
  • you moved your project outer of dev – user147874 Aug 30 '18 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.