0

I installed a Let's Encrypt cert, then did a database S&R (with serializing/unserializing support) for http://mydomain to https://mydomain .

The certificate works and I get a valid HTTPS connection, and all files and interior pages work. But the front page does not, returning a 404.

I have tried everything I can think of within WordPress - resetting / changing permalinks, disabling custom theme and plugins, recreating htaccess, etc. I thought perhaps server support for https, so I tried an entirely different host (actually an AWS ec2 server with bitnami wordpress) and had the exact same issue.

I am assuming this is an apache virtual host configuration, but I've added in the AllowOverride in several places. I'm not a systems administrator.

Here is my question - based on the interior rewrites working, what might that imply is wrong for the front page?

Here's a clue I think, from the Query Monitor plugin:

Request index.html

Matched Rule ([^/]+)(?:/([0-9]+))?/?$

Matched Query name=index.html &page=

Query String name=index.html

All Matching Rewrite Rules (.?.+?)(?:/([0-9]+))?/?$ pagename=$matches[1] &page=$matches[2] ([^/]+)(?:/([0-9]+))?/?$ name=$matches[1] &page=$matches[2]

It looks like it is looking for a WordPress page named index.html, right? It's almost like the rewrite is TOO aggressive, not aggressive enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.