0

I run my own VPS, which hosts multiple WordPress websites. When it comes to adding/removing Plugins via the WordPress Dashboard, I have never had a problem.

For one of my domains, I wanted to perform a clean WordPress install as to troubleshoot some issues. Upon doing so, I noticed that the following pop up would appear when trying reinstall Plugins onto the clean WordPress installation:

enter image description here

Initially, I saw that the issue could be to do with the file permissions. As such, I changed the file permissions as follows:

  • Folders: 755
  • Files: 644

I have also tried inserting define( 'FS_METHOD', 'direct' ); into the wp-config.php file. Whilst this removes the request for FTP Login credentials, it does produce the following error message:

Installation failed: Could not create directory.

Regardless, I should not need to add additional lines of code to the wpconfig.php file, since my other domains did not need it. Even if this did work, I feel it would had been masking the issue rather than solving the source of the issue.

Unfortunately, the issue still persists. What else could be causing this issue? I thought it may had been to do with the VPS but my other domains do not seem to have the same issue.

Further Findings ...

I have just re-uploaded a Backup of my Web Files, as to compare, and found that the 'User' and 'Group' column had different entries for the .htaccess file as follows:

Working Web Files

enter image description here

Problematic Web Files

enter image description here

Could this be the issue? If so, how could I amend this, in order to 'my fto useraname' and 'pssacIn' entries to 'root'?

1

Make sure that your web server user has ownership of the directories where WordPress is installed. If you don’t know the username run the following command:

# ps aux | egrep '(apache|httpd)'

Next, to make sure that your web server user has ownership of the directories where WordPress is installed, run the following command:

# chown -R apache /var/www/html/
  • Thanks for your time. I have just uploaded a backup of my previous Web Files and noticed different entries within the 'User' and 'Group' columns as per the amendment to my question. Is this in line to what you are indicating? If so, how could I go about making the relevant changes? – Craig Aug 19 '18 at 23:31
  • You have to do those changes from the SSH of you VPN. – Castiblanco Aug 19 '18 at 23:35
  • I have logged in via PuTTY. Are you saying to simple enter # chown -R apache /var/www/html/ or do I need to modify this entry in order to reflect the change in 'User' and 'Group' entries? – Craig Aug 19 '18 at 23:39
  • Run the first command to know the user, then run the second command changing the user (apache) and also changing the directory. – Castiblanco Aug 19 '18 at 23:57
  • 1
    Not really sure what had happened, since the 'User' and 'Group' entries have remained the same. That said, your answer has worked! Thanks. – Craig Aug 20 '18 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.