-1

So i apologise as i am a complete newb to wordpress and phpmyadmin.

So i tried to authenticate my website with google authentication but inputted the incorrect url address in the wordpress dashboard. After a lot of hassle with failed login attempts to PHPmyadmin i corrected the home and site URL in the wp-options section. I tried to go to my website and got the error "Error establishing database connection" To fix this i have been following youtube videos but have hit a roadblock as the PHPmyadmin database doesn't have the wp-config file in to alter the text.

Another issue is wordpress doesn't recognise the email address that i have my website associated with (I've checked the username and password in the wp-user section of PHPmyadmin), it does recognise a username i use for other things but haven't for wordpress, either way, when i ask for a password reset by email, nothing comes through to any of my email accounts.

If i have confused you with my naivety on the subject i apologise but any help would be greatly appreciated. Thank you for your time. Sam

  • 1
    wp-config.php is not a database record, this is the file residing more likely in the root of the WordPress installation. For email check the "Spam" folder. – Max Yudin Aug 8 '18 at 14:21
0

Google authentication sounds like the least of your worries.

wp-config.php lives in the public_html folder of your website, not in SQL database.

Assuming everything else is configured correctly, then you will simply need to put your SQL info into wp-config.php and then go to your main website url via the browser

      If wp-config.php doesn't exist in /public_html folder, then look for wp-config-sample.php and rename it to wp-config.php

The last issue you're encountering with the email address and user id is rather surprising if you're generating a database connection error...

  • Thanks for the help bulldog. I think i have a few separate issues going on. I cannot get access to my file manager on cPanel as now the FTP server is now connecting so am currently on hold on the phone to my web hosting providers trying to rectify the issue. i will update when this is solved, but i really appreciate the quick response and help. – Sam Aug 8 '18 at 17:12
  • Sounds good. This might be the rare case where a simple delete and install from scratch makes sense -- once you get your access issue figured out. – bulldog Aug 8 '18 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.