0

Like the title says, new posts and pages do not automatically have comments enabled, even though I have the option checked in discussion settings. Any ideas why it may not be working?

2
  • Do you mean that if you create a page, the comments checkbox is turned off, even though discussion settings has them on by default? Or do you mean you have comments turned on but no comment form or comments are shown on the frontend?
    – Tom J Nowell
    Aug 1 '18 at 23:34
  • comments checkbox is turned off even though discussion settings has them on by default Aug 4 '18 at 14:22
0

It could be a plugin that is modifying comment settings. First place to look.

Then look at a new post/page. Are comments enabled for that page by default? (On the page/post edit screen, use 'screen options' to ensure that 'comments' checkbox is enabled, so you see that setting underneath the post content area.)

Do you get the same results when you change to one of the 'twenty' themes?

More info needed, but those are the first places to check, iMHO.

1
  • only plugin i could think of is one that allows me to add categories to pages, all others shouldn't affect them. Comments is checked in screen options. Same issue in twenty themes. I do use a self-created theme so I wouldn't be surprised if that were the issue, but as I've changed to the twenty-seventeen theme and still seen no issues, I'm inclined to believe that it's a plugin issue, I'll have to go through and manually disable each of them, see if that fixes it. Aug 4 '18 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.