0

I've Googled this question in a large amount of sites, but I've not found any good solution.

The problems seems a common one, on the web. These are the details...

If I try to upload a file directly in the Media Library section, Chrome console shows two calls to /wp-admin/async-upload.php file: first one returns a success 200 reply (and the file is uploaded), second one shows a 303 forbidden reply, so the file is not shown.

Reloading the page, my picture is there... what a mistery!

The real problem comes when I try to attach a featured image to a post: the libray does not show up! Well, the window pops up, but the loader keeps on spinning, and no images is shown. If I try to upload a new image, I receive a WP error, telling me that the upload failed to complete. This time Chrome console shows several call to admin-ajax.php, no JS/PHP errors but no results.

I tried several tricks, like modifying the first lines of async-upload.php to make AJAX always active, but this is not the solution.

Image files, pdf files,... no difference! The problem is still there.

Server log file does not show anything relevant to me.

Any good hint?

Thanks

Wordpress v4.9.7 (same problem with prev version)


EDIT

I've noticed that a similar issue rise up when I try to update a plugin. The update seems to fail, an error message tells me the following

Update failed: {"success":false,"data":{"update":"plugin","slug":"login-recaptcha","oldVersion":"Versione 1.2.3","newVersion":"","plugin":"login-recaptcha\/login-nocaptcha.php","pluginName":"Login No Captcha reCAPTCHA","errorMessage":"L'aggiornamento del plugin non \u00e8 riuscito."}}

But, refreshing the page, the plugin is correctly up to date!

  • have you checked the permissions on the folders, you are uploading your images to..? – honk31 Jul 25 '18 at 10:37
  • Permissions are OK, because the image, as I said, is uploaded correctly. Permission on folder are 0755. – Simone Conti Jul 25 '18 at 13:05
  • so inside the folder, there is your image AND all the other resized images, that wordpress creates (eg. thumbnail, large, medium, etc., depending on the size of your original image)..? – honk31 Jul 25 '18 at 16:40
  • Yes, inside uploads/2018/07 folder there are all image format created by WordPress. I can add that, uploading a file (image or pdf... doesn't matter), directly in the library, using the browser uploader instead of the multiple (ajax) uploader, everything works fine. The problem is that I cannot do it when I try to use a file as featured image, as you sure understand! :( – Simone Conti Jul 26 '18 at 6:51
0

Problem solved. I really don't know how, but a simple javascript, that was executed in frontend only, was affecting the image loader.

I removed it.. all works fine (I hope!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.