1

our website is http://syno-int.co.kr and using wordpress. I tried to install robots.txt to plugin section, but when I put zip file in it, it shows like this.

Unable to create directory wp-content/uploads/2018/07. Is its parent directory writable by the server?

What should I do? Please let me know. Thank you!

0

There are two possible solutions, you can try:

Solution 1 – Changing Uploads Directory In WordPress Settings

If you have moved your WordPress to a new hosting recently. There is great chance that path to your WordPress uploads directory is incorrect. Follow below steps to correct/verify settings.

  1. Sign in as admin on WordPress
  2. click on Settings tab
  3. select Media.
  4. Under the section titled Uploading Files, you should see a field named Store uploads in this folder. Now check the path to Uploads directory.

  1. Once you are sure that uploads directory in WordPress settings is correct press Save button and try to upload files again.

Alternate Method for Solution 1:

If you’re unable to see the uploads directory field in WordPress admin area. Use File Manager or FTP and open up the wp-config.php file for editing. And add the following code:

define( 'UPLOADS', 'wp-content/uploads' );

This code should be included before this line:

require_once(ABSPATH . 'wp-settings.php');

Now try to upload media files again. If you still get error proceed to Option 2.

It is may be better to reset the folder permissions of your uploads folder. For this, you can use an FTP client, like FileZilla or File Manger as well. Follow these steps to reset folder permissions using FileZilla:

  1. Connect to your account with FileZilla.
  2. Go to WordPress installation directory (in most cases it’s public_html) and open wp-content folder.
  3. Once inside, right-click on the Uploads directory.
  4. Click on File Permissions, which will prompt open a dialog box.
  5. Here, find the Numeric value field, and enter 755.
  6. Check the Recurse into subdirectories option if not already checked.
  7. Select Apply to directories only from the radio buttons.
  8. Click OK.

enter image description here

Hope it helps! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.