Migrated from Stackoverflow & Unix & Linux:

Recently I tried to setup a Wordpress server on Fedora28 based droplet on Digital Ocean. A followed some tutorials and the result was the same: After a "successful" Wordpress installation I couldn't add new plugins etc. Followed some resolving methods(debug, tutorials etc.), I found that it could be something about the unsuccessful SSH connection between Wordpress app and Wordpress.org.

Then in a tutorial a read the following, which is for Ubuntu and for older version PHP, but I found intresting:

sudo apt-get update
sudo apt-get install php5-gd libssh2-php

This will allow you to work with images and will also allow you to install plugins and update portions of your site using your SSH login credentials.

My question is: Is there really something about some missing parts of php-ssh installation or I failed at some other part of configuring the LAMP/Wordpress environment?

Thank you!

Update:

I managed to find and installed the appropriate library for Fedora28: see how But the root of the problem has not been solved with it, since I have no add new plugin possibility in Wordpress dashboard still.

  • try this code in a single file <?php echo file_get_contents("https://secure.php.net/file_get_contents"); if you don't see the PHP manual, look the error message. – mmm Jul 21 at 15:04
  • I did what you proposed and got the File not found.. – Geeocode Jul 21 at 15:13
  • @mmm does it mean something useful for you? – Geeocode Jul 21 at 15:26
  • which file ? what is the complete error message ? – mmm Jul 21 at 15:31
  • @mmm This is the complete error message. – Geeocode Jul 21 at 15:33

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.