2

I have a xampp configurated locally to run wordpress. I must have done something wrong when fixing some issues 'cuz at the end, I got stuck with the following log from mysql database.

2015-11-10 15:26:56 10fc InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-11-10 15:26:56 4348 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2015-11-10 15:26:56 4348 [Note] InnoDB: The InnoDB memory heap is disabled
2015-11-10 15:26:56 4348 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-11-10 15:26:56 4348 [Note] InnoDB: Memory barrier is not used
2015-11-10 15:26:56 4348 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-11-10 15:26:56 4348 [Note] InnoDB: Not using CPU crc32 instructions
2015-11-10 15:26:56 4348 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-11-10 15:26:56 4348 [Note] InnoDB: Completed initialization of buffer pool
2015-11-10 15:26:56 4348 [Note] InnoDB: Highest supported file format is Barracuda.
2015-11-10 15:26:57 4348 [Note] InnoDB: 128 rollback segment(s) are active.
2015-11-10 15:26:57 4348 [Note] InnoDB: Waiting for purge to start
2015-11-10 15:26:57 4348 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.26-74.0 started; log sequence number 1835027
2015-11-10 15:26:57 6140 [Note] InnoDB: Dumping buffer pool(s) not yet started
2015-11-10 15:26:57 4348 [Note] Plugin 'FEEDBACK' is disabled.
2015-11-10 15:26:57 4348 [Note] Server socket created on IP: '::'.
2015-11-10 15:26:57 4348 [Note] Event Scheduler: Loaded 0 events
2015-11-10 15:26:57 4348 [Note] C:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '10.1.8-MariaDB'  socket: ''  port: 3306  mariadb.org binary distribution
2015-11-10 15:27:11 5152 [Note] C:\xampp\mysql\bin\mysqld.exe: Normal shutdown
--------

2018-07-19 21:28:34 568 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2018-07-19 21:28:34 1384 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2018-07-19 21:28:34 1384 [Note] InnoDB: The InnoDB memory heap is disabled
2018-07-19 21:28:34 1384 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2018-07-19 21:28:34 1384 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2018-07-19 21:28:34 1384 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-07-19 21:28:34 1384 [Note] InnoDB: Using generic crc32 instructions
2018-07-19 21:28:34 1384 [Note] InnoDB: Initializing buffer pool, size = 2.0G
2018-07-19 21:28:34 1384 [Note] InnoDB: Completed initialization of buffer pool
2018-07-19 21:28:34 1384 [Note] InnoDB: Highest supported file format is Barracuda.
2018-07-19 21:28:34 1384 [Note] InnoDB: The log sequence number 0 in ibdata file do not match the log sequence number 49463 in the ib_logfiles!
2018-07-19 21:28:34 1384 [Note] InnoDB: Restoring possible half-written data pages from the doublewrite buffer...
2018-07-19 21:28:34 1384 [Note] InnoDB: Creating tablespace and datafile system tables.
2018-07-19 21:28:35 1384 [Note] InnoDB: Tablespace and datafile system tables created.
2018-07-19 21:28:35 1384 [Warning] InnoDB: Resizing redo log from 2*320 to 2*16384 pages, LSN=53524
2018-07-19 21:28:35 1384 [Warning] InnoDB: Starting to delete and rewrite log files.
2018-07-19 21:28:35 1384 [Note] InnoDB: Setting log file D:\xampp\mysql\data\ib_logfile101 size to 256 MB
2018-07-19 21:28:35 1384 [Note] InnoDB: Setting log file D:\xampp\mysql\data\ib_logfile1 size to 256 MB
2018-07-19 21:28:35 1384 [Note] InnoDB: Renaming log file D:\xampp\mysql\data\ib_logfile101 to D:\xampp\mysql\data\ib_logfile0
2018-07-19 21:28:35 1384 [Warning] InnoDB: New log files created, LSN=53772
2018-07-19 21:28:35 1384 [Note] InnoDB: 1 rollback segment(s) are active.
2018-07-19 21:28:35 1384 [ERROR] InnoDB: Plugin initialization aborted at D:\win32-packages\build\src\storage\xtradb\srv\srv0start.cc [2969] with error Generic error.
2018-07-19 21:28:35 1384 [ERROR] Plugin 'InnoDB' init function returned error.
2018-07-19 21:28:35 1384 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2018-07-19 21:28:35 1384 [Note] Plugin 'FEEDBACK' is disabled.
2018-07-19 21:28:35 1384 [ERROR] Unknown/unsupported storage engine: InnoDB
2018-07-19 21:28:35 1384 [ERROR] Aborting

this guy here seems to repeat itself a number of times - I know, It is specific. I know, I almost know it like poetry but still, I can not find the solution. I have tried several methods found all over the internet, some of them be

*deleting ib_logfile0 and ib_logfile1 *increasing InnoDB buffer pool size *removing the 'sys_malloc' from db configuration

Bellow I'll paste the my.ini file of my sql server

    # Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# D:/xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is D:/xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client] 
# password       = your_password 
port            = 3306 
socket          = "D:/xampp/mysql/mysql.sock"


# Here follows entries for some specific programs 

# The MySQL server
[mysqld]
innodb_force_recovery = 4
port= 3306
socket = "D:/xampp/mysql/mysql.sock"
basedir = "D:/xampp/mysql" 
tmpdir = "D:/xampp/tmp" 
datadir = "D:/xampp/mysql/data"
pid_file = "mysql.pid"
# enable-named-pipe
key_buffer = 20M
max_allowed_packet = 1M
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 20M
log_error = "mysql_error.log"
innodb_use_sys_malloc = 1


# Change here for bind listening
# bind-address="127.0.0.1" 
# bind-address = ::1          # for ipv6

# Where do all the plugins live
plugin_dir = "D:/xampp/mysql/lib/plugin/" 

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
# 
# commented in by lampp security
#skip-networking
#skip-federated

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id   = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = "D:/xampp/tmp"
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "D:/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "D:/xampp/mysql/data"
#innodb_log_arch_dir = "D:/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 200M
innodb_additional_mem_pool_size = 200M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 200M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

## UTF 8 Settings
#init-connect=\'SET NAMES utf8\'
#collation_server=utf8_unicode_ci
#character_set_server=utf8
#skip-character-set-client-handshake
#character_sets-dir="D:/xampp/mysql/share/charsets"

[mysqldump]
quick
max_allowed_packet = 20M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

I'm quite newbie to mysql, and trying all those stuffs without even changing the error... sucks. And I'll probably suck more untill I rock (ya, I just did that one for not letting you guys take advantage). Cheers!

  • innodb_log_file_size should NEVER be smaller than innodb_log_buffer_size. You appear to have them reversed for the sizes to make sense. REMOVE innodb_additional_mem_pool_size = 200M from your my.cnf it is DEPRECATED. – Wilson Hauck Feb 26 '19 at 1:50
0

This is how I approached to solve the problem.

I have fixed the issue. From xampp/mysql/backup/ folder i copied all files in to xampp/mysql/data/ That solved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.