1

I am currently working on a multisite. I have deleted one of my microsite, let's say the microsite url is mysite.com/barrie/, but after deleting my microsite it's url is redirecting to a random post which have a url like this mysite.com/barrieawn-care-advice/

I just want to that if i deleted my microsite then it should display 404 not found page.

1
  • Random post url is like mysite.com/barrie-lawn-care-advice/ Jul 7, 2018 at 13:40

1 Answer 1

1

In this case WordPress is doing what it ought to.

Because you deleted your underlying website, the URL no longer redirects to the blog but uses fuzzy matching to pull up the closest relevant post.

While I would not recommend it, you could follow this route to disable fuzzy matching Disable ONLY URL auto complete, not the whole canonical URL system

NOTE: I have not tried that solution.

To avoid these collisions, I recommend using subdomains like barrie.mysite.com.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.