0

I am trying to work on a new Wordpress-site on the web. I am 'hiding' the site by putting up index.htm in the home-directory so that visiters see this html with some text about 'maintenance' and not the Wordpress-site.

But now if I go to www.example.com/index.php it redirects to www.example.com/ and shows the index.htm. I can't preview what I am doing in the admin.

Is there anyway I can change Wordpress-settings so it won't redirect /index.php to /?

Thanks in advance.

2
  • Use FileZilla to rename index.htm to something else and then visit. There is no setting in WP to handle this. – Rutwick Gangurde Oct 11 '11 at 9:45
  • Ok, thanks for the answer. I know now I don't need to look into Wordpress-settings. – Jelle Oct 11 '11 at 10:15
2

A good solution to your problem would be to use a maintenance mode plugin. These plugins will show a splash page to your visitors, but allow administrators full access to the site.

You can find these plugins in the Plugin Repository, for example: http://wordpress.org/extend/plugins/maintenance-mode/

1
0

Under settings in WordPress you can decide where you want your WordPress site displayed.

Under Settings->Site address (URL), for example if you decide to display your site in a subfolder like this http://example.com/temp/

You just gotta create a folder called "temp" place your index.php file in there and edit it.

Change this line:

require('./wp-blog-header.php');

to

require('../wp-blog-header.php');

0

Change site URL because wordpress redirects to it automatically we can't do it normally use default but it happens in this type of conditions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.