1

I tried to update my WordPress version but it didn't work. If I log in I get the message

Database Update Required. WordPress has been updated! Before we send you on your way, we have to update your database to the newest version. The update process may take a while, so please be patient.

After clicking Update now I get the Message

Update complete. Your WordPress database has been successfully updated.

But after clicking on OK I get the first message again.

After reading a couple of threads I tried this:

but nothing worked. I still can't get to the backend.

Could anyone help me with this problem?

0

For anyone stumbling across this now, I might have the solution. If you've tried the above steps provided by OP, instead of matching the database functions lower the db_version value in the wp_options by 1. In case your $wp_db_version in your version.php is 45805 (as was the case for me), try setting your db_version value in the wp_options table to 45804.

Doing so will set your WordPress to prompt you to update the database once again when you visit the /wp-login or /wp-admin screen. This, again in my case, solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.