1

I have the following website: www.bibaboegifts.be.

Any idea why this is the case & how this can be resolved?

2 Answers 2

1

This can happen for several reasons - in your case, it looks like you are using a caching plugin that only recognizes www links. I suspect if you turned off caching you would not have that problem, but then you'd lose the benefits of caching.

It's best practice (with or without caching) to add redirects so only the www or non-www version of your website can be seen. You can add a line or two in your .htaccess file to enforce whichever you prefer - which in your case is probably www.

RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteCond %{HTTP_HOST} ^(.*)$ [NC]
RewriteRule ^(.*)$ https://www.%1/$1 [R=301,L]

These 3 lines say, if someone tries to access your site without "www." in the URL, the server should always redirect them to the "www." version of that URL. This helps search engines know which version of your site you want indexed, and if you use SEO plugins that add canonical URLs, will help reinforce the 1 and only 1 version of each page that should be recognized.

2
  • Thanks for your reply. I tried to disable the cache plugin (WP Rocket), but the issue still occurs. Will try to adapt the .htaccess file later on.
    – BarrieO
    Jun 27, 2018 at 15:10
  • 1
    Was resolved by adding the code to the .htaccess file. Thanks Elaine!
    – BarrieO
    Jun 28, 2018 at 7:02
1

As you have mentioned that you have already disabled caching plugin and checked. So not sure what is causing this issue. But as per my knowledge, your website must only open with or without www (any one of these).

So I always use below code in my .htaccess to redirect non-www URLs to www URLs.

RewriteEngine On
RewriteCond %{HTTP_HOST} ^yourdomain.com [NC]
RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [L,R=301]

So when the user tries to access the website without www, the user will automatically be redirected to URL with www.

Maybe this can help you to resolve your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.