0

I have a running CentOS 7 with Apache 2 mariadb stack with vhosts and Let's Encrypt. I've installed WordPress 4.9.6 on a virtual host using debian style (sites-available -> sites-enabled).

My problem is that I cannot use permalinks. I copy my server configuration below.

getenforce 
Disabled

/etc/httpd/sites-available/example.com.conf:

<VirtualHost *:80>
    ServerName www.example.com
    ServerAlias example.com
    DocumentRoot /var/www/example.com/public_html
    ErrorLog /var/www/example.com/error.log
    CustomLog /var/www/example.com/requests.log combined
RewriteEngine on
RewriteCond %{SERVER_NAME} =example.com [OR]
RewriteCond %{SERVER_NAME} =www.example.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

/etc/httpd/sites-available/example.com-le-ssl.conf:

<IfModule mod_ssl.c>
<VirtualHost *:443>
    ServerName www.example.com
    ServerAlias example.com
    DocumentRoot /var/www/example.com/public_html
    ErrorLog /var/www/example.com/error.log
    CustomLog /var/www/example.com/requests.log combined
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/example.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/example.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/example.com/chain.pem
</VirtualHost>
</IfModule>

Apache configuration file /etc/httpd/conf/httpd.conf:

<Directory />
    AllowOverride none
    Require all denied
</Directory>

DocumentRoot "/var/www/html"

<Directory "/var/www">
    AllowOverride None
    Require all granted 
</Directory>

<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Config. file on the public_html directory /var/www/example.com/public_html/.htaccess:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L] 
RewriteCond %{REQUEST_FILENAME} !-f 
RewriteCond %{REQUEST_FILENAME} !-d 
RewriteRule . /index.php [L] 
</IfModule>
# END WordPress

I've enable permalinks settings on WordPress admin:

https://example.com/%postname%/

Permissions of .htaccess file are:

-rw-r--r-- 1 apache apache 235 Jun 24 13:54 .htaccess

sudo httpd -M shows:

(..)
 rewrite_module (shared)
(..)
0

For the next person, be sure to set AllowOverride All in the correct directory. In Damon's case he set AllowOverride All in the /var/www/html directory, but his site is located in /var/www/example.com/public_html. I could be wrong, but the AllowOverride setting is specific to the directory. Damon should add the AllowOverride All setting to the /etc/httpd/sites-available/example.com.conf and /etc/httpd/sites-available/example.com-le-ssl.conf files. Without this setting the .htaccess file wordpress uses will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.