0

I apologize in advance if this is wrong place to ask my question (mods: please move it to appropriate place)


I'm seeing following message in my wordpress logs:

PHP Warning: include(): Unable to allocate memory for pool.

and/or

PHP Warning: Unknown: Unable to allocate memory for pool. in Unknown on line 0

php -v:

# php -v
PHP 5.3.3 (cli) (built: Nov  7 2016 11:21:30) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
# 

memory_limit and/or apc.shm_size set to 128M:

# grep ^memory_limit ./php.ini
memory_limit = 128M
# grep ^apc.shm_size ./php.d/apc.ini 
apc.shm_size=128M
# 

I've tried setting memory_limit to -1 and/or 512M for test, yet same results (message above).

Please advise.

  • WordPress enforces it's own memory limit on top of the php.ini's limit. It's possible that's the issue. Take a look at my answer here for more info and a potential solution. – DaveLak Jun 22 '18 at 17:00
1

Does this topic help (it appears to be referencing the items you are looking at currently) https://stackoverflow.com/questions/3723316/what-is-causing-unable-to-allocate-memory-for-pool-in-php ?

  • No, not really... I've tried to research for this issue prior asking my question and I find few similar to that posts, but that did not help resolve my issue( – alexus Jun 22 '18 at 20:16
0

I had a similar problem. I caused it when tried increasing my memory limits by editing the. htaccess, wpconfig and wpsetup files. Undoing my changes didn't help so I just started over since it was a new setup. I would look at these files as a starting point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.