0

I'm new to Wordpress, and I set up a test installation on FreeHostingEU.com. I decided to move to a different host (still to be decided), so I wanted to migrate the site to my local server.

I first tried doing this with the "All-in-One WP Migration" plugin, which failed, so I tried the Duplicator plugin. The Duplicator reported that the host had some restrictions (easy to believe), which prevented a normal duplication, and it suggested trying a "two-part install", which means copying all the files in WP directory manually from the FreeHostingEU to my local directory and using Duplicator to copy the database.

I followed the instructions for a two-part install, meaning:

  • I copied all the files from FreeHostingEU via FTP and pasted them into my local installation (i.e., I replaced the default WP files on localhost with the downloaded files).
  • I used the Duplicator installer.php to import the exported database.

The Duplicator script reported that everything went OK, but when I try to load the site (on localhost), I just get a blank page.

Please note that the server works OK otherwise (I can see and use the default Wordpress installation on localhost; it only stops working when I try the Duplicator import).

I came across this answer and this guide from this post, so I went into my database and checked the following options in table "wp_options", but they seem to be correct (set to localhost).

+-----------+-------------+------------------+----------+
| option_id | option_name | option_value     | autoload |
+-----------+-------------+------------------+----------+
|         2 | home        | http://localhost | yes      |
|         1 | siteurl     | http://localhost | yes      |
+-----------+-------------+------------------+----------+

What else could be going wrong? I might be missing something obvious, being a newbie and everything, but if anybody has come across a similar situation, I would appreciate any suggestions.

UPDATE:

I found a bunch of perhaps relevant errors in the PHP error log. The first one that came up seems to be

WordPress database error Unknown column 'wp_' in 'field list' for query SELECT wp_, referer: http://localhost/wp-admin/setup-config.php?step=1&language=en_GB

followed by many others such as

PHP Fatal error: Uncaught Error: Call to undefined function utf8_decode() in /var/www/wp-demo/installer.php:5062\nStack trace:\n#0 {main}\n thrown in /var/www/wp-demo/installer.php on line 5062, referer: http://localhost/installer.php

I know that file "installer.php" was created by Duplicator to import the exported copy into my local server.

  • check the php error log for errors – Mark Kaplun Jun 17 '18 at 7:17
  • in general you should ask the plugin author for help, seems like it depends on the xml php extension to be active – Mark Kaplun Jun 17 '18 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.