recently moved my wordpress directory so that core files are in public_html/wordpress and site is accessible via root directory (ie www.mydomain.com instead of www.mydomain.com/wordpress/)

i followed the instructions at inmotion hosting for moving wordpress from subdirectory, and also I have run the velvet blues url updater and as far as i can tell when looking in wp-options table in database, everything has updated to new url. however, i cannot get my site logo to display.

I have deleted it from avada theme options> logo and then reloaded it again all to no avail.

Short of deleting it from the media library altogether and uploading it again (i am not entirely convinced this will work actually), I am at a loss as to know what to do. I am having the same issue with images generally on the website.

I have checked the location of the file in cpanel file manager and it is in the exact location that is referred to in the web broswer (ie right click in google and choose inspect element)

I am sure i have overlooked something...or inadvertantly performed an additional unecessary task that has caused this...?

When i move/migrate a WP site, i usually use this handy tool: https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

With this tool you can replace strings in the database.

Upload srdb to the root and extract (example.com/srdb/_all_files).

Then go to http://example.com/srdb.

You should do the following replace.

Search: example.com/wordpress
Replace by: example.com

NOTE:
ALWAYS MAKE A FULL DATABASE BACK-UP WHEN YOU USE THIS TOOL! USE ON YOUR OWN RISK.

NOTE 2:
DO NOT FORGET TO COMPLETELY REMOVE IT WHEN YOU'RE DONE!

  • I began to suspect that caching has something to do with it. I changed the website logo to a completely different image uploaded directly from my desktop pc. I cleared the cache in two web browsers then navigated to the site. It is still showing the original logo (which of course is not loading). I dont have any caching plugins on the site, i cant figure where the caching is coming from? I should also add, this all came about at the same time as i changed the site directory and added ssl....i wonder if the ssl has something to do with it? – adam Jun 8 at 7:05
  • can you share a link? – Bjorn Jun 8 at 7:07
  • wtf...when i link to it from here everything is fine...hmmm – adam Jun 8 at 7:11
  • Ok, so the website (avada) is still loading the img with /wordpress/ in the url. It's not a cache/cookie issue, i've never been on your website before. Did you try the DB search and replace tool i mentioned? It always helps me with problems like this. It's easypeasy ;-) EDIT: it's still broken here. – Bjorn Jun 8 at 7:14
  • Another thing, i'm assuming you don't have a caching plugin like W3 total cache active. Disable all caching plugins. – Bjorn Jun 8 at 7:53

i think i have problem sorted...i forgot to alter the index.php file from

require( dirname( FILE ) . '/wp-blog-header.php' );

to read

require( dirname( FILE ) . '/wordpress/wp-blog-header.php' );

  • 1
    no. while this might have solve the specific issue, you should never change core files. This indicates a problem with you webserver configuration that should be solve, not worked around – Mark Kaplun Jun 11 at 3:42
  • ... not meaning that something is wrong with the webserver, but that something you have done is not compatible with its settings – Mark Kaplun Jun 11 at 3:43
  • agreed. i wasnt meaning i altered core files, what i meant was that when giving wordpress its own directory, usually the procedure is only a 3 step process. 1. move index.php and .htaccess to root (leaving core files in subdirectory), 2. editing the index.php file to tell web browser where the core file now are, 3. alter wordpress dashboard settings "site url" to reflect mydomain.com instead of mydomain.com/wordpress. In my case i cannot seem to get it working using the method outlined in wordpress codex. – adam Jun 11 at 22:52

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.