My hosting company has moved my site www.technologyedge.biz to SSL and it shows the padlock with a warning ! on Chrome. When I use F12 to see the problem, I see these errors, what does this mean and how do I fix it:

GET http://www.e3technology.in/WordPressSample/wp-content/uploads/2015/07/logo_01.gif 404 (Not Found) (index):179 GET http://www.e3technology.in/WordPressSample/wp-content/uploads/2015/07/logo_03.gif 404 (Not Found) (index):178 GET http://www.e3technology.in/WordPressSample/wp-content/uploads/2015/07/logo_02.gif 404 (Not Found)


3 Answers 3


As mentioned in the other answer, that's because the URL for the image is http, not https, so you get a 'mixed content' message from the browser. Equivalent to "You are on an https connection, but one of the images you got came from a http connection. That means that that image is not being sent via SSL (https), which means the request (in this case an image) is not being sent securely.'

To fix this, you have to change the URLs of all links on your site to https. This can be difficult for large sites (or even small ones).

I like to use a plugin called 'Really Simple SSL', which will do all of the tasks needed to ensure that each request is returned via SSL. There are other similar plugins, but this one has worked well for me.

  • I really don't like that plugin, since it's very inefficient, but I understand why people are using it, since it's pretty easy... Jun 5, 2018 at 20:29
  • YMMV, but I don't agree that it is very inefficient. Sure, it intercepts any requests for the local site and redirects to the https version, but that doesn't take much 'time'. I haven't done any benchmarks, but the plugin authors state "n a site where the source consists of about 60.000 characters, the delay caused by the mixed content fixer is about 0.00188 seconds.". Not a worry, IMHO. And support is great; the developer answers quickly. Yes, there are manual ways to do this, but many will want a 'just works' solution. Jun 6, 2018 at 1:29
  • It depends on site and on settings. If you will turn all of their "methods", then it will get much worse, I guess. And the main problem I have with that plugin is... since SSL migration is something you do only once, then there's no point in having a plugin that will "convert" your site to SSL every time on every request... Jun 6, 2018 at 4:10
  • I think that you need to look at the code to see what they are doing. There is not a 'something you do only once'. The plugin fixes mixed content requests on the fly as needed. It ensures that any http local request is converted to https, so you don't get mixed content warnings. It does not change content in the database that I can see. It just ensures that any http request to local resources are changed to https requests. There are other plugins that will modify the database, looking for http-local and changing to https-local. But this plugin ensures all http requests are changed to http. Jun 6, 2018 at 18:31
  • oh believe me, I’ve looked at that code many times and audited it. And that is the problem - they do on the fly something that should be done once during SSL config. Doing it on the fly makes no sense at all, and can be very inefficient and harmful in some cases... Especially if someone inexperienced uses some of their settings... (for instance converting using JS). But that’s not the part of the question, so let’s leave it there :) Jun 6, 2018 at 18:37

It means that somewhere on your site you link to these images and they are not server using SSL secured connection - they use HTTP and not HTTPS.

How to fix that? You should find these images (in your code, content, or wherever they are) and change them so they're served using SSL connection (so change http:// to https://)


I believe that you may actually have two different issues here. But without further information, I can't be certain.

The 404 errors you are describing are a result of a file not found, not an insecure request. Verify that the files do indeed exist.

Once you've done that open the page and your developer tools. Make sure that you are on the Network tab and that you are showing the 'Scheme' column in your output.

If you order by scheme you can scroll through all of the requests and identify which requests are made using http (rather than https). You'll have to locate each item that is requested via http and update it to request via https to prevent the security warning.

Modern browsers display this warning when some requests aren't made using ssl (http).

If you have shell access you can also use wp-cli to quickly update all of the urls. See this article for easy instructions.

It also appears as if your certificate is invalid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.