1

when i try to open my multisite network dashboard from this:-

http://domain.com/wp/wp-admin/network/

it's gives me this statment:-

This page isn’t working domain.com redirected you too many times. Try clearing your cookies. ERR_TOO_MANY_REDIRECTS

[Update] see the link to resovle above issue:- Redirect loop (only for multisite network admin)

  • its eaither an htaccess issue or a problem with your DB. How did you install your WPMS? – Aurovrata May 28 '18 at 11:21
  • @Aurovrata when i creating WPMS this issue occured, but before all that i changed my site url and home url directly from DB. – Hussain Jbair May 30 '18 at 5:44
  • how did u change the home/site url from the DB? – Aurovrata May 30 '18 at 5:52
  • @Aurovrata see this link codex.wordpress.org/Changing_The_Site_URL on this section Changing the URL directly in the database – Hussain Jbair May 30 '18 at 6:03
  • please read through my answer below, did u follow step 2? is this a fresh installation of WordPress or you copied the db from your local machine? – Aurovrata May 30 '18 at 6:09
1

If you install your WordPress Multisite (wpms) from scratch on the server this issue should not arise. However, if you have installed your wpms on a local machine first and then moved/copied the entire installation including the database to your server, then you have to ensure that,

  1. you modify the domain in your database. I am not aware of any plugins that handle wpms installation till date. However, I use the Interconnect/it search and replace db tool. You need to search for 'localhost/folder' and replace with 'your-domain.com'. The best results is to ensure that you have a similar setup on the localhost as the server. If you are looking to setup wpms with subdomains, I suggest you create the child sites on the server after successful installation, and export/import pages/posts for the local machine to the server.
  2. you also need to change the wp-config.php wpms settings, define('DOMAIN_CURRENT_SITE', 'localhost'); define('PATH_CURRENT_SITE', '/local-folder/'); to define('DOMAIN_CURRENT_SITE', 'your-domain.com'); define('PATH_CURRENT_SITE', '/'); //or a sub-folder name is not a root installation.

keep in mind that a lot of things can go wrong with such a procedure, and therefore it is always much simpler to install your wpms from scratch on the server and export/import content from one local to server.

[EDIT] In case you have created a fresh installation, then the likely issue is that you have either a problem with your htaccess file or with the site_url/home_url settings.

If you have misconfigured your site_rule/home_url in your dashboard then you need to change it directly in your database. Follow these instructions, and assuming from your question that you have installed your WordPress files in the sub-folder /wp, make sure that,

  1. If you want to access your site with: domain.com and your dashboard with domain.com/wp-admin, then

siteurl = http://domain.com home = http:/domain.com/wp

  1. If you want to access your site with domain.com/wp and your dashboard with domain.com/wp/wp-admin then,

siteurl = http://domain.com/wp home = http:/domain.com/wp

[EDIT 2] One more possible reason is the browser caching. 301 redirects are cached by the browser, so clear your cache. You can inspect what kind of redirection your browser is experiencing by looking at the request trace on the network tab of the inspector console. This can give you a clue as to where the redirection is being applied.

  • yes i changed according to step 2, but this not my issue -> the problem with network dashboard viewing – Hussain Jbair May 30 '18 at 7:06
  • do you get the same error when you view domain.com/wp/wp-admin? Are you able to see the front end domain.com/wp? – Aurovrata May 30 '18 at 7:57
  • no error ocurred just on domain.com/wp/wp-admin/network/ , yes i mention this eariler – Hussain Jbair May 30 '18 at 8:10
  • you did mention earlier, but you didn't say that it was working with the rest of the dashboard! that rules out a lot of possibilities. Did you clear your browser cache? This can be a reason as 301 redirects are cached! what type of redirection are you getting when you inspect your request trace on the network tab of your inspector console? – Aurovrata May 30 '18 at 8:40
  • yes i cleared my browser cach eariler, it's document type – Hussain Jbair May 30 '18 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.