0

My site redirects a number of times before it lands. This issue occurred once the SSL certificate was implemented. Any ideas on how to fix this problem.

My site is posted with Vidahost - I asked them for help but they haven't a clue.

Unfortunately my programming skills a basic but if someone could point me in the right direction, I could probably solve it.

https://boconlineblog.co.uk

Many thanks in advance

# BEGIN Really_Simple_SSL_HSTS
<IfModule mod_headers.c>
Header always set Strict-Transport-Security: "max-age=31536000" env=HTTPS
</IfModule>
# END Really_Simple_SSL_HSTS
# BEGIN Really_Simple_SSL_UPGRADE_INSECURE_REQUESTS
<IfModule mod_headers.c>
Header always set Content-Security-Policy "upgrade-insecure-requests;"
</IfModule>
# END Really_Simple_SSL_UPGRADE_INSECURE_REQUESTS

# BEGIN rlrssslReallySimpleSSL rsssl_version[2.5.26]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTPS} !=on [NC]
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>
# END rlrssslReallySimpleSSL
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php71” package as the default “PHP” programming language.
<IfModule mime_module>
  AddType application/x-httpd-ea-php71 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit
0

You probably need to change your 'WordPress Address (URL)' and 'Site Address (URL)' to include the 'https' instead of the 'http' in your WordPress settings page under: Settings -> General Settings

If this doesn't fix it, then try getting it working with the 'Really Simple SSL' plugin: https://en-gb.wordpress.org/plugins/really-simple-ssl/

Update

After taking a look at your sites .htaccess file, I think the issue is being caused by the following lines:

RewriteCond %{HTTP_HOST} boconlineblog\.co\.uk [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ boconlineblog.co.uk/$1 [R,L]

Try removing these lines and see if that fixes the issue.

Update 2

Try disabling the Really Simply SSL plugin and deleting everything from your .htaccess file except the following:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php71” package as the default “PHP” programming language.
<IfModule mime_module>
  AddType application/x-httpd-ea-php71 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit`
  • Hi Mat, I've tried all those things yet it still doesn't work – Joesph Priestley May 11 '18 at 10:22
  • Can you share your .htaccess code? And you don't have 'WP_HOME' or 'WP_SITEURL' defined anywhere in your wp-config.php file do you? – Mat May 11 '18 at 10:28
  • # BEGIN Really_Simple_SSL_HSTS <IfModule mod_headers.c> Header always set Strict-Transport-Security: "max-age=31536000" env=HTTPS </IfModule> – Joesph Priestley May 11 '18 at 12:20
  • # END rlrssslReallySimpleSSL # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress RewriteCond %{HTTP_HOST} boconlineblog\.co\.uk [NC] RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ boconlineblog.co.uk/$1 [R,L] # php -- BEGIN cPanel-generated handler, do not edit # Set the “ea-php71” package as the default “PHP” programming language. – Joesph Priestley May 11 '18 at 12:21
  • <IfModule mime_module> AddType application/x-httpd-ea-php71 .php .php7 .phtml </IfModule> # php -- END cPanel-generated handler, do not edit – Joesph Priestley May 11 '18 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.