1

Could someone explain or show me a link to learn why when you ftp an image to uploads/sites/<blog_id>/ folder it does not show in the image gallery? Image gallery as in the one you see all your images in.

I'm using multi site. I could not find any documentation on why. Im transferring large amount of images onto a new sever.

  • 1
    Uploading the image is only one part of the process. When you add media to your site via the Media Library, it's actually added as an attachment, a built-in post type that carries with it a bunch of metadata. Simply FTPing images into the appropriate directory doesn't create the associated attachment post or set any of the metadata. – Pat J Apr 26 '18 at 14:37
  • Oh wow! I never knew that. I guess I need to search for some sort of plugin to handle this. – Sylar Apr 26 '18 at 14:38
  • 2
    A quick Google search led me to this plugin, which might do what you need. – Pat J Apr 26 '18 at 14:39
  • 2
    @PatJ, please make an answer out of those comments – Mark Kaplun Apr 26 '18 at 15:30
  • @MarkKaplun -- done. – Pat J Apr 26 '18 at 16:50
3

Uploading the image is only one part of the process. When you add media to your site via the Media Library, it's actually added as an attachment, a built-in post type that carries with it a bunch of metadata. Simply FTPing images into the appropriate directory doesn't create the associated attachment post or set any of the metadata.

A bit of quick Googling led me to the Add from Server plugin, which might do just what you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.