0

My environment:

# cat /etc/debian_version 
9.4
# apache2ctl -version
Server version: Apache/2.4.25 (Debian)
Server built:   2018-03-31T08:47:16
# openssl version
OpenSSL 1.1.0f  25 May 2017
# php -v
PHP 7.0.27-0+deb9u1 (cli) (built: Jan  5 2018 13:51:52) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.27-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
# 

I followed Administration Over SSL « WordPress Codex and before wp-settings.php is required, I set:

define('FORCE_SSL_ADMIN', true);

yet in Google Chrome, I keep getting:

This page isn’t working

fqdn redirected you too many times. Try clearing your cookies.

ERR_TOO_MANY_REDIRECTS

and via curl:

$ curl -v https://fqdn/wp-admin/
* About to connect() to fqdn port 443 (#0)
*   Trying X.X.X.X...
* Connected to fqdn (x.x.x.x) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
* Server certificate:
*   subject: CN=fqdn
*   start date: Apr 24 13:53:39 2018 GMT
*   expire date: Jul 23 13:53:39 2018 GMT
*   common name: fqdn
*   issuer: CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US
> GET /wp-admin/ HTTP/1.1
> User-Agent: curl/7.29.0
> Host: fqdn
> Accept: */*
> 
< HTTP/1.1 302 Found
< Date: Wed, 25 Apr 2018 14:51:43 GMT
< Server: Apache/2.4.25 (Debian)
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Link: <https://fqdn/wp-json/>; rel="https://api.w.org/"
< Location: https://fqdn/wp-admin/
< X-Content-Type-Options: nosniff
< X-Frame-Options: sameorigin
< Content-Length: 0
< Content-Type: text/html; charset=UTF-8
< 
* Connection #0 to host fqdn left intact
$ 

Please advise.


workaround: if I go to https://fqdn/wp-admin/index.php, everything works without any issues...

2
  • Do you have a reverse proxy as codex.wordpress.org/… suggests **these options will initially send any requests into an infinite redirect loop. ** – Clemens Tolboom Apr 25 '18 at 15:27
  • @ClemensTolboom, no reverse proxy at the moment, just apache/php-fpm. – alexus Apr 25 '18 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.