0

I installed multisite on my WordPress account which is hosted on a wordpress optimized account on Hostgator.

Now when I want to log in to wp-admin the url shows: http://wp67.hostgator.com/~waf6tq0adwzk/wp-login.php?redirect_to=http%3A%2F%2Femeforero.com%2Fwp-admin%2F&reauth=1

My wp-config.php is

define('WP_DEBUG', true);
define ('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
define('DOMAIN_CURRENT_SITE', 'emeforero.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1); 
define( 'NOBLOGREDIRECT', '' );    
define( 'WP_HOME', 'http://emeforero.com/' );
define( 'WP_SITEURL', 'http://emeforero.com/' );

and my htaccess is:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

Thanks!

1

Log into the admin area, then check the URLs in Settings, General. Those values should be similar to http://www.example.com .

The wp_options table in your database also has two entries for the site URLs. They should be the same as in Settings, General, but doesn't hurt to check things. If you can't login as admin, then check those two entries in the wp_options table for the correct URLs.

Then open a new, private browser window and login. (That reduces chance of your browser caching things.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.