0

The issue is the websites stemmed from our WordPress multi-site area going into a reload loop on initial load.

Note,this is not a redirect loop, but the page continually attempts to reload in quick succession and doesn't load on first go.

If you do a hard refresh or press ctrl + F5 the website loads fine. This only occurs when you are logged in as an admin user of the Multi-site environment.

We have attempted to resolve by disabling plugins 1 by 1 including any cache related plugins.

Which leads me to think the issue is with the .htaccess file settings for the multi-site environment?

Relevant part of the .htaccess file is below:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
# add a trailing slash to /wp-admin #
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
</IfModule>
2
  • Can you edit your question to include your .htaccess file contents (at least the WordPress-relevant parts of it)? There's a set of sample .htaccess files on the Codex—are you sure you're using the correct one for your Multisite installation?
    – Pat J
    Apr 17, 2018 at 14:03
  • Thanks Pat. I've now included that. Sorry really should have had that in there to start.
    – MagentoMac
    Apr 17, 2018 at 19:39

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.