0

Since updating my server to PHP 7, I have an error thrown when I try and login to the back side. The front end works but I am unable to login to the backside. Here is the error message:

Fatal error: Uncaught Error: Using $this when not in object context in /www/wp-content/plugins/MyFontsWebfontsKit/mf-options.inc:28
 Stack trace:
 #0 /www/wp-includes/class-wp-hook.php(286): MyFontsSettings_3496500::adminInit('')
 #1 /www/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
 #2 /www/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
 #3 /www/wp-admin/admin.php(156): do_action('admin_init')
 #4 /www/wp-admin/plugins.php(10): require_once('/www/wp-admin/a...')
 #5 {main} thrown in /www/wp-content/plugins/MyFontsWebfontsKit/mf-options.inc on line 28

When I disable the MyFonts plugin the error goes away. Is my thinking correct? - It is a problem with the MyFonts WebFont Plugin? Thanks in advance for your thoughts!

closed as off-topic by Krzysiek Dróżdż, Nathan Johnson, Jacob Peattie, cjbj, TheDeadMedic Apr 19 '18 at 16:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Krzysiek Dróżdż, Nathan Johnson, cjbj, TheDeadMedic
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Hello and Welcome to WP Stack Exchange! Keep in mind this is a QA site not a discussion forum, so you need to be able to mark an answer as correct, in the canonical concrete works for all users with that problem way. It looks like you've found a PHP 7 bug in the MyFontsWebFontsKit plugin, have you opened a support ticket with the maintainer? – Tom J Nowell Apr 17 '18 at 3:03
  • Thank you for your help. Yes, I have reached out to the developer but I am still waiting to hear back. – Wade Apr 17 '18 at 15:56
1

Yes, the error is caused by the MyFont's plugin (or whatever it is called).

You should go to their support forum for help, after making sure that you have the latest version (download/ftp transfer manually, or reinstall via Add Plugin).

  • I appreciate your help. I have reached out to the developer and I am awaiting a response. – Wade Apr 17 '18 at 15:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.