2

I have been digging through stuff and I can't seem to find any other reason for the "Another update is currently in progress."

To clarify I have already tried the Fix Another Update Is In Progress Plugin. It says "There is no issue. Continue with your WordPress Update".

However, if I try to update I still get this message. What else, besides the options database entry lock, can cause this?

I have this problem and it is driving me crazy.

  • There is NO option in my DB to lock. Not the core_updater option or the core_updater.lock option.
  • I have looked manually.
  • I have ran sql searches.
  • I have tried the plugin for this. All say this option does not exist in my db.
  • I have turned off caching.
  • I have deleted the cache.
  • I have waited.
  • I have restarted my server.
  • I have even spammed a select statement while trying to update to see if it appears momentarily and have not seen it.

Is there any other possible cause? I am getting this error but there is NO LOCK OPTION in the database.

It is quite annoying.

I even manually updated last update to see if it would fix it. It did not.

Thank you for your help and suggestions.

UPDATE

I have gone in and logged the queries it runs for updates. I checked to make sure NO core_update.log was present. Started recording and got this.

event_time;"user_host";"thread_id";"server_id";"command_type";"argument"                
2018-04-17 09:38:14;"root[root] @ localhost [::1]";"361";"1";"Query";"SELECT option_value FROM wp_options WHERE option_name = 'auto_core_update_failed' LIMIT 1"                
2018-04-17 09:38:15;"root[root] @ localhost [::1]";"361";"1";"Query";"INSERT IGNORE INTO `wp_options` ( `option_name`    `option_value`  `autoload` ) VALUES ('core_updater.lock'    '1523979495'    'no') /* LOCK */"
2018-04-17 09:38:15;"root[root] @ localhost [::1]";"361";"1";"Query";"SELECT option_value FROM wp_options WHERE option_name = 'core_updater.lock' LIMIT 1"

I almost looks like it adds the lock file, then checks if its there during the update. Then spits out the error. Almost like it's running this stuff in the wrong order.

closed as off-topic by Jacob Peattie, Nathan Johnson, cjbj, TheDeadMedic, Jack Johansson Apr 20 '18 at 19:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Jacob Peattie, Nathan Johnson, cjbj, TheDeadMedic, Jack Johansson
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This may help: Get rid of Another update is currently in progress – admcfajn Apr 16 '18 at 17:47
  • This does not help. The plugin says it is fine and there is no core_update option in the database. But I am still getting this message when trying to update WP. – user1518699 Apr 16 '18 at 17:58
  • MySQL returned an empty result set (i.e. zero rows). (Query took 0.0720 seconds.) SELECT * FROM wp_options WHERE option_name LIKE '%core_update%' – user1518699 Apr 17 '18 at 15:32
  • Good sleuthing, that's a weird one. Have you tried manually updating? ie: downloading WordPress from wordpress.org & replacing all the core-files? Have your tried disabling all plugins &/or using a default-theme before running the update? – admcfajn Apr 18 '18 at 15:05
  • 1
    I'm not sure why this is "put on hold". All of this info is related to the initial issue. It's just that the normal/standard fix is not working. – user1518699 Apr 25 '18 at 20:16
1

It should last more than 15 minutes. See if there is .maintenance folder in WordPress installation folder or execute following command from wp-cli

$ wp option delete core_updater.lock
  • The site is not in maintenance mode. There is no core_updater.lock option. What else can cause this? – user1518699 Apr 16 '18 at 17:56
  • I had same problem some times ago and the method worked for me. it worked after 15 min in another case. And yes, you should view this thread too: wordpress.stackexchange.com/questions/224989/… – Milan Bastola Apr 16 '18 at 18:02
  • I have looked at that thread and it doesn't address the issue. I DO NOT have this option in my WP database but am still getting this message when I try to update the core. What else can cause this? – user1518699 Apr 17 '18 at 2:26
  • If you can login to dashboard: wordpress.org/plugins/fix-another-update-in-progress this plugin can help you. for detailed instruction please go through this tutorial: wpbeginner.com/wp-tutorials/… – Milan Bastola Apr 17 '18 at 2:46
  • @MilanBastola this plugin says that everything is fine... – user924 Jul 21 '18 at 16:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.