0

I'm fairly new to WordPress and now having a problem with multisite set-up. I manage to follow the steps to get the code to add both to wp-config and .htaccess files, but after saving the changes and trying to login back to WordPress to continue setting subdomains up, I'm suddenly not able to login back to the admin view. I'm working on the localhost, and when I sign-on via http://localhost/wordpress/wp-admin/ I just end up seeing by blog UI, but now admin dashboard/tools "around it". Something definitely works as there are no error messages or redirecting issues when I log in, but just the admin view is missing.

I have tried to clean up the browser history and also login with different browsers, but with no success. Also, I have disabled plugins.

I wonder if someone has had a similar issue and can help out?

0

"White screen of death" or similar problems usually indicate a 'fatal' plugin problem.

You should look at the error.log file (usually in your site root, but could also be in the wp-admin folder) via your FTP/host File Manager, and look at the latest error. It will usually tell you the file that caused the problem.

If it is a plugin folder, temporarily rename that folder via FTP/File Manager and reload the admin page. It should come up.

Then you can investigate the plugin via it's support page (better there than here).

You can also post the error here, but I suspect a plugin is causing the error.

  • Thanks for quick help! I'm not having complete white screen, I can still see then content of my site (almost) normally, but just can't access the dashbaord to administrate / develop it further. Anyway, I have already tried renaming the blugin folder from "plugins" to "pluginsX" to prevent it working, but still the same end result :( I tried to look for a error.log file, but I could only find files called ErrorHandler, ErrorLogHandler, class-wp-error etc. I wonder which one of these is the error file to look into more detail? – Marika P Apr 14 '18 at 18:32
  • You can turn on the debug option in the wp-config.php file. The error.log file will be in the root folder of your site; also look in the wp-admin folder Turning on debug might show additional error messages. Try also changing back to one of the 'twenty' themes (you can do that by renaming your theme's folder in wp-content/themes/your-theme-name . When the current theme is not found, WP will revert to a 'twenty' theme. And start a private instance of your browser to reduce chances of caching not letting you display the page. – Rick Hellewell Apr 14 '18 at 18:50
  • I turned debugging on and found some information from a file called "debug" (from folder wp-content). That didn't contain any logs from this issue (just from another issue where I had added one wrong row to my config file). I also tried to trick of disabling my current theme, vogue. That resulted to my breaking down my blog site --> meaning when I earlier tried to login to the admin view, I just get to my site. After disabling current theme, it gave me just white screen. Also tried doing all this in private mode, but the result was the same in all scenarios as in normal mode. – Marika P Apr 15 '18 at 11:00
0

This could be a difficult one to answer remotely, so here are some things to check. Just maybe something in this response points you in the right direction: The steps I usually follow when implementing multi-site:

  1. Turn off all plugins;
  2. Copy wp-config.php and .htaccess file;
  3. Open wp-config.php and add define('WP_ALLOW_MULTISITE', true) just above the stop editing;
  4. In WordPress admin, go to Tools >Network Setup. You’ll be prompted to choose subdomains or subdirectories for your installation: choose the one that works for your network;
  5. Edit the title of the network and email address of the network administrator when prompted, or leave them as they are;
  6. Click install;
  7. Update wp-config.php and .htaccess as directed in on the installation screen.

The .htaccess file should look something like this:

Options +FollowSymLinks
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

# END WordPress

Other settings you may need to use in your wp-config.php are

define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
define('DOMAIN_CURRENT_SITE', 'yoursite.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);
define('SUNRISE', 'on');

If you find something in here, great, otherwise, sorry I couldn't be of more help.

  • Thanks for this. This is actually exactly what I have been doing so far, and right after completing these steps and trying login back to admin dashbaord, it just directs me to my blog view, but not to the admin view. – Marika P Apr 15 '18 at 10:49
  • Does it redirect you when you type in the .../wp-admin.php or after typing in the username and password? – Clinton Apr 15 '18 at 17:47
  • 1
    In newer versions of Wordpress, define('WP_ALLOW_MULTISITE', true) may now be define('MULTISITE', true) – Kyle Calica-St Feb 22 at 0:43
0

Strangely it worked for me (on more than one multisites) to set SUBDOMAIN_INSTALL to false. To be honest, I hadn't had time to investigate further why ...

define('SUBDOMAIN_INSTALL', false);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.