1

Im currently working on my Customizer, and i just started off, when i reallised that there is a problem.

I added a new section, control and setting to change the color of h1, and everything works in the customizer. When I click on publish however, there is a red error box telling me that there have been problems with saving.

When I try to close the customizer, there is error message telling me that I have unsaved changes. When I close that, the changes I just made are still beeing saved.

<?php


function JK1_customize_register( $wp_customize ) {


   // Panels, Sections, Settings


  $wp_customize -> add_section('font_section', array(

   'title' => __("Font Setting"),
   'description' => __("Change Font Settings here"),

  ));

   $wp_customize -> add_setting('font_setting', array(

   'default' => '#000000'

   ));


  $wp_customize -> add_control(new WP_Customize_Color_Control($wp_customize, 'font_control', array(

   'label' => ("Stelle Farben ein"),
   'section' => "font_section",
   'settings' => "font_setting"

   )));




}

 add_action( 'customize_register', 'JK1_customize_register' );

?>

<?php

include "css_customize.php";

?>
  • Can you post your code? – Andy Macaulay-Brook Apr 5 '18 at 17:28
  • I had this is in the customiser on one site. Checking my PHP log I saw that it was a memory issue. – Peter HvD Apr 6 '18 at 9:18
  • Please check the PHP error log. – Weston Ruter Apr 7 '18 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.