1

I have the following custom post-type:

<?php

function university_post_types() {

  // Professor Post Type
  register_post_type('professor', array(
    'supports' => array('title', 'editor', 'thumbnail', 'excerpt'),
    'public' => true,
    'labels' => array(
      'name' => 'Professors',
      'add_new_item' => 'Add New Professor',
      'edit_item' => 'Edit Professor',
      'all_items' => 'All Professors',
      'singular_name' => 'Professor'
    ),
    'menu_icon' => 'dashicons-welcome-learn-more'
  ));

}

add_action('init', 'university_post_types');

Within my functions.php file I am registering my theme support the following:

function university_features() {
  add_theme_support('title-tag');
  add_theme_support('post-thumbnails');
  add_image_size('professorLandscape', 400, 260, true);
  add_image_size('professorPortrait', 480, 650, true);
}

add_action('after_setup_theme', 'university_features');

My problem is that no, featured-image box is showing within my custom post type.

Any suggestions what I am doing wrong?

I appreciate your replies!

  • 1
    Do you mean that you don't see the option to add a featured image in the editor when editing a post of that post type? – George Kendros Mar 26 '18 at 20:23
1

Maybe you could try specifying the post type when you declare the support

add_theme_support( 'post-thumbnails', array( 'post','professor' ) );

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.