0

Environment is Wordpress 4.94 Multisite with numerous blogs up and running. This issue affects this blog only and is not affecting the others.

When uploading an image or PDF (or other asset) to the Media Library the upload works and the file can be sourced on the server. Image sizes are generated as expected, and all urls to those files are accessible in the detail view in Media Library.

However when uploading recent files to the Media Library the default placeholder image is being shown, not the thumbnail for the image or the PDF icon for those files.

Additionally - the key difference to other similar issues - is that the filename is not showing on top of the thumbnail nor is it seen in the detail view.

Image of files uploaded missing filenames

Upon investigating the wp_postmeta table I have discovered the new uploads have no entries.

Screenshot of empty wp_postmeta query

I have tried the usual bug-finding steps such as turning off individual plugins and setting the theme to twentysixteen but it persists.

Any suggestions or ideas on how to debug this further?

  • Is there anything in your /wp-content/debug.log? If you don't see that file, set define('WP_DEBUG', true); define('WP_DEBUG_LOG', true); in your wp-config.php and try uploading some attachments again. Also, have you tried spinning up a new multisite instance and uploading the same files? You can probably get some more help here by providing a list of your plugins and the theme being used. You can also start debugging by looking at what WP is doing in methods like wp_insert_attachment in wp-includes/post.php. – phatskat Mar 23 '18 at 16:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.