0

Wordpress 3.9.4 upgrade to the latest version is giving the following error.

Download failed.: SSL certificate problem: unable to get local issuer certificate", "Installation Failed".

1 Answer 1

2

This error indicates that your SSL certificate has either expired or is corrupted. I came across this error recently on a local Wordpress installation and the solution is as follows:

  1. Download the latest cert.pem file from https://curl.haxx.se/docs/caextract.html
  2. Save this file (called cacert.pem) in your php installation directory
  3. Open php.ini in an editor and search for curl.cainfo
  4. If this exists and is commented out (';' in front) delete the ';' and add the full path to the cacert.pem file
  5. If this does not exist find [curl] in php.ini and add the line curl.cainfo = "C:\Program Files (x86)\PHP\v5.5\cacert.pem" where the path is to your cacert.pem file. For example, my php.ini file looks like this
[curl]
; A default value for the CURLOPT_CAINFO option. This is required to be an
; absolute path.
curl.cainfo = "X:\xampp\php\cacert.pem"

After you have done this restart your web server.

Your Wordpress upgrade should work after this has been completed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.