0

Here's an overview of how I have things setup:

All of our domains are registerd with GoDaddy and our web hosting is with Siteground.

I have the main hosting account domain (domain.com) currently pointing to a Shopify store.

I then have an add-on domain setup (domain.net) which I've setup as the main WordPress Multisite Network site.

I've also got our German domain setup as an add-on domain (domain.de).

Both the .net and .de domains have their DNS pointed to the Siteground hosting.

I've setup a subfolder network site for the German site (domain.net/de) and this works great.

However, I've tried to then set this subfolder site up so that it works from the domain (domain.de) but I can't seem to get this working. Either when I have the add-on domain setup to have the same 'home' folder as the .net domain, or if parking the .de domain with a redirect to the .net site.

Our main site is running WordPress 4.9.4 so I don't believe we need a plugin such as 'WordPress MU Domain Mapping' to get this working (although I have tried that method too).

With the .de add-on domain set in the hosting to point to the .net domains home folder, the closest I get to it working is the Siteground 404 page.

I'm pretty stuck on this now so any help would be greatly appreciated. Also, if you need any clarification on anything or have any questions, please do ask.

Hope to hear from some of you soon!

  • This sounds like a case of the host automatically adding .htaccess rules. Since it's a localized issue it's more appropriate to ask the host themselves how to set this up. They likely have dealt with this type of setup before and know what steps to take to get things working. Also note that as you change settings, you may need to use a HTTP header checker or an Incognito window to make sure your own browser hasn't cached redirect rules, meaning that once you try to see the site and get redirected, even if you then fix the issue and then try to see the page, your cache still redirects. – WebElaine Mar 5 '18 at 14:27
  • 1
    @WebElaine - Thanks for the response. Sitegrounds support team was able to resolve this for me today. It was just a case of re-issuing the Let's Encrypt SSL certificate, so nothing to do with WordPress Multisite in the end after all... I was sure I had it all setup correctly... Just wish I'd not spent so much time on it before contacting them (I didn't actually think they would help support the install but was getting desperate to get this working). – Mat Mar 6 '18 at 1:43
0

Ok, so this actually turned out not to be a WordPress or Multisite issue after all. It turned out that it was actually a problem with the Let's Encrypt SSL certificate that was causing the issue. Re-issuing the Let's Encrypt SSL fixed this for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.