After a server update, I got some problems on my website, running WordPress 4.9.2

I could not update WordPress version to 4.9.4, cause I was getting a message like this:

Another update is currently under way.

I finally manually updated WordPress, but this did not solve another problem:

Of course my user has an administrator role: I can edit already existing posts or pages, but I cannot add anything new, it says I have not the permissions.

In the "Add new" page in the admin, I can't see the Publish button (as usually), but just a "Send for revision" button.

And clicking "Send for revision" button doesn't work, getting this message:

You have no permission to edit this post.

Also other parts of this page are missing (like format list, permalink), looking like sort of broken page (see screenshot).

I tried with some research, but I could find really nothing that could give me at least a small idea of what is the problem.

  • folders in FTP seem to have right permissions (755, 644)...
  • all plugins and WordPress version are updated
  • already tried to disable all plugins
  • .. depending maybe on some settings of the server?

Does anyone know on what could this problem depend?

enter image description here

  • Did you create a new admin user and tried to edit/publish it with that user ? – Beee Mar 3 '18 at 12:51
  • I just tried, I did not think about this... It's really weird, I add a new admin user, I can see a new row in the user list, but name is not displayed and in role it says "None" (so actually, user was not added). It looks really like something is broken, but I don't know what. – supadema Mar 5 '18 at 14:05
  • There's only 1 solution :) debug it until you find the error. You said you tried to deactivate all plugins. So that didn't work ? If not, try to revert to a default theme. Did that change anything ? If so, it's in your theme somewhere and you need to find debug it some more. – Beee Mar 5 '18 at 15:42
  • I tried switching to another default theme, but was not there the problem. Probably the server update has done some damage to the database, cause it lost some structure settings as AUTO_INCREMENT and Primary Key. This is why I was not able to add any post, user, etc. from admin panel. I follow these instructions to fix it: wordpress.stackexchange.com/questions/225641/… – supadema Mar 6 '18 at 15:19
  • good luck, i hope you fix it. – Beee Mar 6 '18 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.