3

directory site that was hosted at https://example.com/mysubdir

Now, I purchased a new domain and added it to my shared hosting account as an add-on domain.

To change the domain settings, I did the following:

  1. Pointed the domain towards the sub-directory (successfully)
  2. Got into the database and updated site URL and site Home to the new domain
  3. Updated site permalinks using Better Search Replace

What's happening is that I can successfully access the home page but all other pages return 500 Internal Server Error. The back-end is though accessible and I can see and edit all pages. But every time I try to view a page with the exception of the home page, I get the 500 Internal Server Error.

I asked my web host about it, and got a link to an article, where they described the process - and it seems to be exactly as I did it with the exception of rewriting the permalinks. But rewriting the permalinks IS necessary.

Can you please help me figure this out?

Just FYI I am using SSL on both domains, that is the sub-directory uses one custom SSL installed at the primary domain and the add-on domain uses another custom SSL. Could that mess things up?

  • 1
    I am thinking it would be your .htaccess file. Rename that file OR Change the Permalinks (if you can access wp-admin) and check if the pages work – Lucky Chingi Feb 20 '18 at 20:26
  • Try visiting the permalink settings page, and also try clearing your cache and/or using an Incognito window. Just visiting permalink settings will flush rewrite rules and you want to make sure you're not seeing cached redirects. – WebElaine Feb 20 '18 at 20:42
  • I often find this is caused by a plugin having a cache file that it thinks is still in the old location. Try turning all your plugins off and then reactivating them one by one. This usually forces them to re-do the cache location. If not, you'll at least know which plugin is causing the issue so you can contact the developer. – Peter HvD Feb 21 '18 at 11:41
1

An update & resolution: I asked the web host for help and they found that I had a piece of code in .htaccess limiting the access to wp-config.php. Once the code was removed, all worked as it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.